On Open Source Software

greenspun.com : LUSENET : Unk's Troll-free Private Saloon : One Thread

Now that Linux, GNU and Open Source software in general are making real inroads in the marketplace, the GNU Public License is coming under a lot of scrutiny.

For those who are unfamiliar with it, basically, if you release a program code under the GPL, you have to give people access to your source code. You have to agree to let anyone copy and distribute the program (source OR binary) at will. Other programmers can modify your original code and redistribute the new program, or derive new programs from your code ... BUT, here's the kicker: the new software MUST be released under the GPL as well.

The implications of this are really beginning to sink in for companies like Microsoft, Novell and Lotus who've made billions selling strict per-user licenses on proprietary software. Microsoft has even gone so far as to distribute internal memos warning employees not to even let GNU code come into the building, lest the GPL "attach" itself to their stuff! :)

Here's one example of the questions being raised now, from Slashdot: a guy does Open Source development on his own time at home, but the company claims ownership under the terms of his contract. The problem is, this code was released under the GPL! The company insists that it has the right to reneg on the GPL, since it's "their" software!


I don't know about you, but I'd NEVER sign a contract with a provision like this, and I agree with most of the posters at Slashdot: I don't think it can be enforced in any event.

But it illustrates an industry that's coming to grips with the future -- namely, free (or nearly-free) software that will finally bust the WinTel monopoly down to its foundations.

-- Stephen (smpoole7@bellsouth.net), March 20, 2002


Stephen, if software becomes free or nearly free, how're the software companies going to make money?

-- helen (waiting@for.linux.to.take.out.my.trash), March 20, 2002.


Red Hat has done it with support and training. They've been so successful that AOL has been trying to buy them, in fact.

There are also plenty of people, like me, who will pay for a CD rather than download the stuff for free, just because it's more convenient (and quicker!).

-- Stephen (smpoole7@bellsouth.net), March 20, 2002.

"just because it's more convenient (and quicker!). "

Says who?

Actually, this IS the next giant leap for the software biz and they know it, it's just a matter of them aligning themselves in the proper position to take the best advantage of it or their diversification into other opportunities. Example : Microsofts' ( & others ) wildly keen interest in the information stored on your computer.

-- capnfun (capnfun1@excite.com), March 21, 2002.


I'm not sure that Microsoft fully "gets it" yet.

Commercial PC software prices, by any rational measure, have generally been outrageous in the extreme in the past. I'm sorry, just because I'm a free-market conservative doesn't mean that I'll pay more than something is worth.

To give you an example, when I can download an office package for *FREE* that will do essentially everything that Microsoft's Office suite will do, how can they justify retailing it for several hundred dollars?

Most businesses that can make a profit of 20-40 cents on the dollar are quite happy. A wildly successful business is one that can double or triple its money.

Compared to these benchmarks, Microsoft is beyond the stratosphere and bordering on outer space.

-- Stephen M. Poole (smpoole7@bellsouth.net), March 21, 2002.

Part of MS's fabulous wealth is based on their historic ability to leverage the work of thousands of outside developers who add value to Microsoft products without MS having to pay them a dime. There are hundreds of thousands of 'experts' in MS Windows, MS languages and MS products, who gain their employment by fixing flaws and filling holes in these products.

The real battle with Linux is the battle for the alligence of these people. Right now, the model is that most developers derive their income working with MS during the day and fool around with Linux/Open Source at night. MS can live with that very happily. The difficulty for MS is that these same developers have become evangelists for Linux and Open Source within their companies, and gradually they are making inroads. That's because the developers would rather work with Open Source during the day, too. The pay's the same and the frustrations are fewer.

-- Little Nipper (canis@minor.net), March 21, 2002.


Yep, that's been my experience, too. Open Source also benefits from the "donated" time of its adherents. The biggest difference is, they actually ENJOY it. :)

-- Stephen (smpoole7@bellsouth.net), March 21, 2002.

Left off a sentence:

And by its very definition, "Open Source" means that they're working with the actual SOURCE CODE, instead of having to use SoftICE or WDEBUG to find out why their driver keeps crashing!

-- Stephen (smpoole7@bellsouth.net), March 21, 2002.

I just wish Linux would benefit the average user. Why must it be so complicated? What's the scoop on Lindows?

-- (LadyVi56@hotmail.com), March 21, 2002.

My experience with Linux has been both exhilerating and frustrating. I love it because I can get the source to something more or less kinda close to what I'm trying to do, but it's hard because often that source is damn buggy, there's zilch for support, comments are rare, it's nearly always joined to some cockamamie hardware platform at the hip, and there are 3 or 4 significantly different development environements, which don't play well together, under which it was built. You just haven't lived if you haven't tried to make significant modifications to inline assembly under GCC.

As a result I've noticed that the attitudes people have vs. MS or Linux tends to be poles apart. If it's an MS product, they dig for, and are shocked! by, every little problem. Aaack!, they say, Windows doesn't work with FlyByNight's incompatible combo USB hub/keyboard/toaster! Yup, those greedy bastards foist crap on us.

Meanwhile, here's a Linux box that supports ONLY hardware version 1.1 of the TEAC USB floppy drive, and only on controller 1, and only when the moon is full, but hey, SOMETIMES IT WORKS! Linux is so wonderful!

As far as I'm concerned, these attitudes are political and not practical. So let me put it to you, Stephen. I have here before me a PC. I won't tell you who makes it, or what hardware I have installed, or what CPU or chipset it's running, or what the clock speed is, or how old it is. It may or may not have ANY local drives. YOUR job is to pick an operating system, install it on this platform, and have everything working as quickly as possible. You get no customer support, you are not a programmer.

Your OS choices are Windows XP, and Linux. On your mark...

-- Flint (flintc@mindspring.com), March 21, 2002.


What amazes me is how much Linux has improved -- sometimes by an order of magnitude -- in a relatively short time. The CD that I tried last year (Red Hat 6.0) ended up in my junk drawer; it was DEFINITELY not ready for prime time. There's just no comparison, and if you'd asked your that question at the time, I would have said, "gimme Windows," period, hands down.

Now? I'm not so sure how I'd answer you. The truth is, Mandrake 8.1 has given fewer problems on an install than Windows 98 or ME, particularly in setting up *secure* networking.

And I refuse to try XP, so I can't comment on it. :)

The sole exception is the old Compaq server at the station, which uses some wierd proprietary hardware. I have to go to "expert" mode and work around a few things there. But on generic, run of the mill PCs, I haven't had any problems. The install has gone quicker and easier than any Microsoft product that I've tried. I even installed a Canon bubblejet on the thing a coupla weeks ago, and set up printer spooling and sharing on my little network at home. No sweat.

For anyone who's interested, here's a pretty good assessment from a guy who has been converting Trust Commerce to Linux -- primarily to save money for his company.

(I am also intrigued at the number of people who compare the KDE desktop to the Mac -- this guy included.)

I'm anxiously awaiting Mandrake's 8.2 distribution. KDE 3.0 is also supposed to have been completely overhauled, and is coming out next month as well. :)

-- Stephen (smpoole7@bellsouth.net), March 22, 2002.

"... fewer problems on an install than 98 or ME ..." and I left out this part: Mandrake 8.1 was DEFINITELY, no-questions-asked and no doubt MUCH easier to install than Windows NT.

I bring that up because Linux should be compared to the NT architecture, and not to the Windows 3.x/95/98/ME stuff to start with. This would affect how I answered your question, too. :)

-- Stephen (smpoole7@bellsouth.net), March 22, 2002.


KDE2 looks amazingly similar to Mac OS and from what Iv'e heard I wouldn't be able to hardly tell the difference. Have you had enough experience with Macs to build an opinion as to the feel and stability of KDE2 vs. Mac? I'm a little curious about this as I am thinking about getting a Mac clone and installing Linux on it, just fer shits and giggles.


"So let me put it to you, Stephen. I have here before me a PC. I won't tell you who makes it, or what hardware I have installed, or what CPU or chipset it's running, or what the clock speed is, or how old it is. It may or may not have ANY local drives. YOUR job is to pick an operating system, install it on this platform, and have everything working as quickly as possible. You get no customer support, you are not a programmer."

I had to chuckle in a way because what was running through my mind as I read that was, "easy answer...buy a Mac".

-- capnfun (capnfun1@excite.com), March 22, 2002.

User-friendly UNIX

-- (Macs@ru.le), March 22, 2002.


That was one of the comments from the link to TrustCommerce that caught my eye: the new receptionist, who'd never seen Linux, found his way around the KDE desktop in no time, remarking that it reminded him of the Mac.

You'd probably feel right at home with it, too, from what I've heard. You can configure it several different ways, too.

People who've stayed in the Apple world rarely have to do bare-bones installs, which is what Flint was talking about. We PeeCee Weenies face that all that time: we'll buy (or build) a clone and then have to install an OS on it from scratch.

I was going to put a Blog about Linux on my Web site, but the TrustCommerce link pretty well covers it for now. I still might address installation issues and newbies, though.

My general conclusion now is, that if your computer skills are limited to clicking icons, you might not want to try Linux just yet. Give it another 6 months to a year (yes, it's improving that rapidly).

For anyone else, though, who have even the merest experience, one of the boxed distributions is fine. The installers are BETTER than Microsoft's, and no longer ask questions about clock frequencies, chipsets and other such nonsense. Mandrake's hardware detection utility was able to sort all of that out for me.

The only confusion is in selecting the packages to be installed. Since I'm not used to classic Unix names, things like "sshd" and "vim" look like Greek to me. I would much rather the installer use plain-English descriptions ("Similar to PC Anywhere, but better" and "classic Unix Text editor") in the list.

At present, it lists the Unix/Geek name, and you have to click it to get the plain English description.

But that's a quibble. A newbie can do the default install and get a machine that works just fine.

-- Stephen (smpoole7@bellsouth.net), March 22, 2002.


May I be so bold as to ask why you refuse to try XP? I'm just curious.

There are few things in this world that I hate but I have to say that XP is quickly joining that short list. I just bought a new Dell and while I love the pc, (it flies!) the OS is most frustrating. O how I wish I would have insisted on 2000! So much for listening to all the MS people telling me how wonderful XP is. I have yet to discover that aspect of it.

-- (LadyVi56@hotmail.com), March 22, 2002.


It's no so much "hate" as a complex of factors.

For one, I have a lot of older DOS software that won't run under NT (which is what XP is). I keep a Win95 machine handy for that (some of it will run under DOSEMU in Linux). I don't like the NT architecture; it's bloated, slow and unreliable. If I've got to have that level of operating system, Linux wins hands down.

For another, I have become increasingly annoyed with Microsoft lately; IMNHO, they are a monopoly and they engage in illegal and unethical marketing practices -- and they remain completely unrepentant about that, with no indication that they EVER plan to change.

(The most recent revelation was that Microsoft strong-armed Dell to stop preloading Linux on some machines. They've got moxie, I'll give them that, seeing as how they were doing this at about the same time that their lawyers were telling the judge that they'd never do such a thing![g])

Bottom line is, I liked Microsoft when it was just one company of many. Now that they've become the Giant Shark, planning to take over the Internet, online banking, Palm computing *and* cable, I've decided that I've been paying my tithes to Redmon for going on 20 years now and that's long enough.

That's just two of many reasons.

-- Stephen (smpoole7@bellsouth.net), March 22, 2002.

Well, a whole buncha comments here.

About a year ago, I upgraded my old computer. It's an AMD 200MHz K6, 32M of RAM, no hard drive (that died). It has been sitting here next to me doing nothing all that time.

So tonight I went out and bought a cheap WD 20G hard drive and Red Hat 7.2. I don't think that BIOS supports booting from CD-ROM, so I'll just have to see what I can do. I'll keep y'all posted. This is a genuine bare-bones Linux installation and configuration. That computer will have nothing Wintel in it whatever.

Yes, Linux has improved a lot in the last year, and improvement continues to be rapid. Most of this seems to be support for an increasingly wide variety of hardware. Linux is reaching (or has reached) critical mass. Take a trip to the bookstore (or amazon), and you find that Linux is included (without the source code to anything) in quite a few of those books. Install it yourself and run. If it were as hard as it used to be, this wouldn't be feasible.

Also, I admit the part of Linux I've been working with is nowhere near stable. We've been trying to create Linux kickstart ROMs for various systems. Who needs a system BIOS anyway? All you really need is to initialize the hardware, configure the RAM, enumerate the PCI bus, and load enough Linux kernel out of ROM to get some drivers installed (like keyboard and hard drive), then continue OS boot from that hard drive.

Now, it should be obvious this is *extremely* hardware-dependent. After all, we're initializing specific chipsets and processors and hard drives. And we don't have 2G of space in ROM to hold drivers for all known devices, either. So this is a case where getting something to actally work at all is a joy.

However, Stephen needs to understand that XP is as far a cry from NT 4.0 as Mandrake 8.2 is from Red Hat 6.0. NT continues to be one of the most miserable experiences in computing. XP is fully (and very capably) plug and play. I've enjoyed it.

Anyway, my plan is to dive into perl and xml as soon as I can learn a few unix commands (and how to use vi, shudder). Off to the world of awk and lex and grep and regular expressions and shell scripts. Should be a trip. The only part I'm really comfortable with is physically installing the hard drive.

-- Flint (flintc@mindspring.com), March 22, 2002.

Well, a whole buncha comments here.

AMD 200MHz K6, 32M of RAM ... Red Hat 7.2 ...

I'd be VERY surprised if RH 7.2 couldn't sort that one out. I have one of the "book" distributions of 7.1 here, and it loaded almost as easily as Mandrake 8.1.

My only comment -- from experience -- would be that you might want to buy another stick or two of RAM, because same as Windows, X runs a bit slow on less than 64M. I have 128M on my machines.

Most of this seems to be support for an increasingly wide variety of hardware.

There are still some gaps, mostly with the Latest, Greatest sound and video cards, but I was surprised at the improvement there, too. Again, with your older machine, Red Hat should have no problem.

Take a trip to the bookstore (or amazon), and you find that Linux is included ...

My only caveat THERE would be to watch the version. (Again speaking from 'sperience.) I bought the Linux Bible without checking too closely; it came with RH 7.0. Certainly functional, but it's an older distribution. It had trouble with one of my video cards.

XP is fully (and very capably) plug and play ... I've enjoyed it ...

OK, I deserved that little scold. I admit it. I will try it. :)

and how to use vi, shudder ...

Peter and Anita would be proud of me; I've learned enough about it to get around OK. But why bother? Just start an X session and use Kate.

A final caveat: when you're first learning the system, I'd set security to minimal to start with.

(It should ask you during install. Do NOT activate a firewall until you know what you're doing, either.)

Otherwise, you'll get a system that fanatically refuses to allow you to even edit most configuration files (because they're owned by Root, and not the current user). Even just trying to copy something from one directory to another is likely to raise a messsage box that whines that "you don't have permission."

But if you log into an X session as Root, it'll say, "this is a bad idea!" :)

(Stephen's power hint there, if you're in X, is to run the file manager in Superuser/Root mode.)

(This is a common complaint from people who are first migrating to Linux from Windows, by the way, and the gearheads are supposed to be addressing it in upcoming distributions. Most Linux developers are longtime Unix freeks who are used to this sort of thing, but if you're more familiar with Windows, it'll drive you CRAZY at first.)

-- Stephen (smpoole7@bellsouth.net), March 23, 2002.


By the way, I apologize for the way that last was worded. I'm sure you "know what you're doing," I meant, don't activate the firewalling until you've had time to get familiar with how LINUX does it. :)

I did so with Mandrake and apparently, the "DrakeWizard" that sets up the firewall also sets up all other sorts of protections. My network became temporarily unusable until I learned how to straighten it out.

-- Stephen (smpoole7@bellsouth.net), March 23, 2002.

Inserted installation disk 1 into the CD-ROM drive, installed the blank 20G hard drive, added 64M of SDRAM, set CMOS Setup to boot from CD-ROM, and fired that sucker up.

Sure enough, after a long list of who knows what, I immediately get to a screen that says:


The installation guide says press Enter, so I do. The screen instantly distorts, as though it were silly putty stretched vertically and shifted 3 inches to the right, so the rightmost third of the screen cannot be seen.

At the bottom of the screen, I'm notified (luckily left-justified) that it correctly identified both my video card and my monitor. Then up pops a screen asking me to select a language. English is highlighted. With the mouse, I can highlight any other language. What I can't do is continue. Enter does nothing, no function keys do anything, tab does nothing. There is probably an OK button off the right side of the screen, but I can't see it. I try moving the mouse off the right side of the screen and clicking at random, but no joy. Nothing works but the power button.

Repeating the process from a cold start doesn't help. The Linux experience has begun.

-- Flint (flintc@mindspring.com), March 23, 2002.

By trial and error, I learned that if I typed "text" at the boot: prompt, it went ahead and completed the installation, allowing me to select every configuration option through the keyboard. Then it formatted the shiny new hard disk, created its default partitions, and spent half an hour copying things off two of the six distribution CD-ROMs. Then I rebooted, and by trial and error got all the way to a $ prompt with only one error, wine:failed. I don't know what wine is, and I have no books that mention it. Maybe this is OK?

Now, how about those other 4 CD-ROMS? Two of them are labeled source code for the system, one is games, and one is StarOffice 5.2

The installation never asked for them. I have no idea what logical drive Linux might think the CD-ROM drive is? Is this something I have to "mount" (whatever that means?). Does it show up as a directory somewhere? So far, I haven't been able to do anything that causes the system to access that drive at all.

I did ask, as part of the installation, to install KDE, GNOME, and X windows. So somewhere there should be three GUIs. But how do I run them? Should I not BE in a GUI at this point?

Of course, I'm assuming that logical drives will show up under a GUI like they do under windows, all nicely labeled like hard drive, or CD- ROM drive, or floppy drive, just like they do under Windows. Maybe it's foolish to expect to be able to run a GUI just because I installed it, or to find drives just because I have them?

Needless to say, there isn't a single word about this situation in the manuals provided with RH 7.2. I guess it's supposed to be intuitive? Do you suppose I should try to keep installing in the hopes that sooner or later Linux will display material properly on a properly identified video card and monitor? I guarantee you, if Windows abused the user anything like this, Microsoft would be out of business tomorrow. Period.

-- Flint (flintc@mindspring.com), March 23, 2002.

Well, even though "text" is a valid boot: option, you get put in an untenable position. You end up with a $ prompt, about as informative and intuitive as the debug - prompt. Forthermore, (and much worse) all "how to continue" material in all the books I have assume you are sitting in some windowing environment, and tell you what to click on. All I got was the $ prompt on a blank black screen. No mouse, no icons, no nuthin.

But wait! Here's an appendix telling how to change environments. Want KDE? (Yes! I want KDE!) Just type "switchdesk" at the prompt. End of advice.

OK, I type "switchdesk" at the prompt. I'm rewarded with an error message telling me I must provide the environment I want to switch to. OK, sounds reasonable. I type "switchdesk KDE" (mind you, there is NO mention of HOW you provide the desired environment, so this is a guess). It sort of works. This time, I get a message telling me that "The KDE environment is now set up". Great. How do I run/enter it? I try "KDE". Unknown command. How about lower case "kde"? Nope, same result. "Exit"? Nope. "Win"? Nope. "/.kde"? Nope. Hey, how about if I ask the manual? I type man switchdesk. This tells me that what I did was correct, and I'm now all setup to use KDE. Nary a word on HOW to use it.

Back to the drawing board. Try re-installing. Nope, same problem with the silly-putty screen. OK, it turns out there are LOTS of commands you can enter at the boot: prompt. Since just pressing "enter" doesn't work, let's be systematic and try them all, one at a time.

After a while, I discover that "nofb" seems to be the right command. This, the book explains, stands for "no frame buffer". What's a frame buffer? I guess if you have to ask, you don't deserve an answer. But some video cards act strange, and this is a way to override the Linux default behavior. Is the standard Matrox Millennium card (what I'm using) one of them? Of course not. This is probably the most common card in the world. Linux knows all about it. Except it's too screwed up to use. Anyway, "nofb" allows me to continue installation (all over again, sigh) in graphics mode. *Leisurely* graphics mode, mind you. One thing "nofb" does is kill graphics performance quite dead. If I ever figure out how to install those games, I hope they're not arcade games. Life is too short.

-- Flint (flintc@mindspring.com), March 23, 2002.

How do you pronounce it?

Linnux or Luy-nux ?

-- Debbie (dbspence@pobox.com), March 23, 2002.


-- (cin@cin.cin), March 23, 2002.

This turns out to be more or less successful. It completes the installation in graphics mode, prompts for the root password provided during installation, and plunks me down in the KDE desktop. This looks very similar to what the manual describes, which is reassuring. The first task, I'm advised, is to create a user, because being root all the time is a bad and dangerous idea. OK, how do I do this?

The manual is very explicit. "In KDE, go to Main Menu => System => User Manager."

Nothing on the screen is labeled "Main Menu". I found a KDE help system, but there is NOT ONE entry under the letter M. The picture in the manual matches my desktop, and THEY don't have a "Main Menu" either. (A footnote here. Linux is quite viciously case-sensitive. Main and main bear no resemblance to one another. Be very very careful about case, or you'll spend lots of time trying to guess how you entered your username. All lower, all caps, first letter caps, or other. This is nuisance for the sake of nuisance, pure and simple).

I tried clicking on every icon both on the taskbar (whatever Linux calls it) and the desktop (whatever Linux calls that). None of them are called Main Menu, and none of them produce anything resembling "System" when clicked. I tried every icon that showed up under any of them, but nothing.

In the process, I discovered something that invited me to change desktops. I chose Gnome (or GNOME, or gnome, I forget). It cheerfully told me I had switched, but nothing changed. Another thing I found was a way to run a shell from KDE. From that shell, I entered "logout" and the screen blacked out. Eventually, it came back and this time it was Gnome (or GNOME or gnome or whatever).

Gnome doesn't have nearly as many buttons as KDE. However, to add users (remember, this is what I'm trying to do), the directions for Gnome (GNOME, I think) say to click on "Start Here". Hallelujah, GNOME does indeed have a button that calls itself "Start Here" when the cursor is placed on it. Further directions are more or less as the manual describes (except for some minor label changes). I'm able to create a new user and become that user.

Unfortunately, the GNOME desktop doesn't show the CD-ROM or floppy devices like KDE did. Nor can I find any way to switch back to KDE. Nor does the shell allow me to log out or log in as root. Note that all of this is *breathtakingly* slow. I'm still not sure if you activate an icon with a single or double click, since I try a single click, nothing happens, I try a double click, nothing happens, I try something else, then something else, then FINALLY the first thing I tried comes up, then over the course of time other things come up as well.

Double clicks are it. But how do I go back to KDE so I can access my CD-ROM? None of GNOME's icons seem to allow anything of the sort. I try the shell, and use "switchdesk". Yep, this says I'm now setup for KDE. I try "logout". Nope, it says to use "exit". I try "exit", it closes the shell window and sends me back to the GNOME desktop!

There are several problems here. I can't find "Main Menu" in KDE, although the manual insists I use it. I can use "switchdesk" when I shell out of KDE, and "logout" to re-enter in GNOME. Great, GNOME matches the manual, but I can't find the floppy or CD-ROM. And shelling out of GNOME won't let me find KDE.

Well, when all else fails...I press the power button, and reboot from scratch. This time, I finally reach KDE, but the taskbar has vanished. I try the KDE control panel, but I get a whole mess of error messages about how Klauncher can't find anything anymore. Nothing works at all. For example, there's a CD-ROM icon, and I can singleclick on it (single clicks seem to work in KDE, double clicks in GNOME). However, all I get is that same Klauncher error message, saying "Klauncher could not be reached via DCOP." Wonderful. What is DCOP? Let's ask the help system. Click on "KDE Documentation" No joy, we get "Could not start process can't talk to Klauncher." NOW what?

Back to the power button. Remember, I created a user under GNOME and logged in to KDE as that user. Maybe KDE doesn't recognize users GNOME creates? I never could find out how to create a user under KDE. I'll try logging in as root again.

This works! But when I enter the shell window, the keywords "logout" and "login" do nothing but kill that window and dump me back and the desktop. So I can't get out of root. I try to search this new session for a "Main Menu", but placing the cursor over an icon no longer produces any messages.

I notice a User Manager in the KDE control panel, and sure enough, I'm able to create a new user using this facility. Again, my attempts to *become* that user fail. There is an icon on the desktop called "Linux Documentation", which looks promising. But of course not, clicking on it simply produces an error message "Unknown host" www.RedHat.com"

I click on the "life preserver" help icon (and wait. Always wait). Finally, I get the glossary, pick a letter. Want to know about users? Sorry, nothing begins with U. A little trial and error shows that unlike the literally many hundreds of help topics you get with Windows, Linux provides about a dozen. So I return to the User Manager, click on the user I want to become now that I've created one, and click on help. This tells me how to create a new user! In other words, you can't get the help until you don't need it anymore!

And through all of this, the window is a 15" window on a 17" monitor, and slightly below and to the left of the actual display. What's on the desktop can be moved so that it can all be seen. What's on the taskbar is tied to the entire window, which can't be moved. In Windows, this would be rejected as a fatal error all by itself. In Linux, I'm thankful I can see anything (I couldn't at first).

Perhaps I'm expected to go out and buy a book on KDE to find out how to become a user rather than root? These books tend to run $50 a pop.

Now, how do I shut down? None of the icons seem to allow this. I'm still root because I can't find how to become a user. The "shutdown" command (that I guessed at, forget about help) asks for options. I provide the options, I just get asked again. No shutdown from the shell, none from KDE either. Back to the power button.

Enough for one day. Anyone who thinks this is as intuitive or natural as Microsoft needs to be led quietly away. I have installed every version of Windows on every imaginable hardware platform. I've watched total novices do the same. Apparently, the "we know the magic incantations" UNIX priesthood orientation is alive and well. Intuitive this is not. I guess I'll spend a few days with whatever books I can find, some of which might more-or-less describe what I see on the screen (since the Red Hat manuals themselves can't come particularly close).

And it's just like I said earlier. Maybe once you've spent enough time in this environment you learn the secret lore necessary to do simple things. Right now, my best option seems to be:

1) set GNOME as the GUI

2) Press the power button to switch environments (if there's any way to do it gracefully, this is not documented or obvious)

3) Once in GNOME, shell out (the GNOME shell seems to do more than simply exit back to the GUI when you issue a command without doing shit).

An alternative might be to install in text mode, and learn whatever it takes to actually access your drives. This might take a week. Contrast with Windows, where you stick in the installation disk, everything is done for you, and when it's finished you can access everything your entire system can do, with full help available for everything at all times.

Yeah, Microsoft might be the big bad monopoly. But dammit, their stuff works easily and correctly.

-- Flint (flintc@mindspring.com), March 23, 2002.


That is amazing. Don't carry me away just yet; maybe Mandrake has a better installer! On my machines, I simply entered the Mandrake CD and pressed "Enter," and Linux installed a useable configuration.

Try running "Xconfigurator" (case sensitive) at a root prompt. It will ask if you want to automatically start X; tell it yes. If you tell it no, you can still start X by entering "startx" at the prompt.

I'm trying to remember version equivalencies: I thought Red Hat 7.2 was basically the same as Mandrake 8.1 ... hold on ... naw, I just checked their Web site, and 7.2 *is* the latest distribution, so I don't understand.

If you're having that much trouble, though, that just confirms what I said above: Linux isn't quite ready yet for the average user.\

Only other thing I can think of is, you don't by any chance have an S3 video card, do you? The readme file included with my stuff here says that it is known to have problems (Windows has trouble with them, too, by the way -- for example, Windows could not detect my network card if I had the S3 in there).

-- Stephen (smpoole7@bellsouth.net), March 23, 2002.


Ooops, OK, I missed that. You have a Matrox Millennium card. Well, then, I don't know what to tell you, except that maybe Mandrake's installer *is* better than Red Hat's. That really surprises me, though.

I promise you, I wasn't pulling your leg. I can put Mandrake's CD into any computer here and it installs like a champ.

(Your guess was right about frame buffers. The system will allocate a linear address region, typically around 400000h, and map the video card's RAM directly into that slot for direct read/write. Without it, you have to use the old VGA I/O process, which is slower than itch.)

If my assumption that Red Hat and Mandrake are essentially equivalent is what has thrown you into Installer Hell, I profoundly apologize. I honestly didn't know.

(And again, I'm surprised. I thought Red Hat would be BETTER than Mandrake! Shows what I know ...)

-- Stephen (smpoole7@bellsouth.net), March 23, 2002.

Ohhhhh.... Good Lord Flint!

Sounds like an awful lot of bullshit just to get a Macintosh interface ; ) Buying one is probably a whole lot simpler, in the long and short run.

If you think Windows is magically simple, give the Mac a whirl, talk about intuitive. I have Windows machine I use to check my burns for PC and I swear I don't see how 94% of the planet thinks it's the best thing sinse sliced bread. I wish I didn't have to have that clunky piece of shit in the same room with me.

-- capnfun (capnfun1@excite.com), March 23, 2002.


Just for fun, I pulled out my Red Hat 7.1 stuff and tried it; you're right, it's a nightmare. I got the stretched screen on a Compaq here with a Matrox video card, so apparently it's a common problem.

I apologize profusely. I naively assumed that Red Hat would be as easy as Mandrake; it is NOT. But again, I assure you, with Mandrake, I slipped in the CD and went from there (even on the Matrox).

During the install, Mandrake asks you to create users; it asks whether you want KDE or Gnome, and if you want them to start at bootup. It even configures your networking and internet connection, all during the install. When you reboot to run for the first time, you get a desktop that's ready to go.

I really do apologize; didn't mean to ruin your weekend. :)


I've told you before, I'd LOVE to have a Mac. Want me to email my snail address to you so you can send me one? :)

I am BAFFLED that Red Hat's installer isn't as easy. It just makes no sense!

-- Stephen (smpoole7@bellsouth.net), March 23, 2002.

Thank you cin.

Amazingly, I have yet to speak the word aloud. When I do, will the gods shine upon me or will they curse me?

Is Lie-nux different from Luy-nux - or it possibly = Lee-nux ? :^)

-- Debbie (dbspence@pobox.com), March 23, 2002.

Turns out KDE's taskbar (when it shows up. That's another problematic thing. It showed up first boot into KDE, then vanished second boot when I logged in as a user rather than root. Appeared again when I logged in as root.) has a logout icon. The annunciator function isn't working anymore (this is very intermittent), so this is coming out of the manual. A small circle with a vertical bar in it is the logout icon. This looks promising, since I want to shut down nice and kosher and reboot. With the text Linux at work, typing "shutdown" as root from the $ text prompt shuts down the system. Not here. I'm root, but I have a graphical environment.

So I click on the logout icon, and I get an "are you sure" window. Yes, I'm sure (remember I could not become a user instead of root under KDE. I'm trying to reboot to become a user because there doesn't seem to be any other method, unlike GNOME). Yes, I'm sure. But does the system shut down? Nope, logout ain't shutdown. Instead, I get a new window asking me to log in again. The power button still works fine.

Back through the cold boot process. By the way, I NEVER want to hear anyone complain that Windows is slow to boot. Win95 on this box boots from the end of POST in about 20 seconds. Linux is about 3 minutes by my watch. Anyway, I finally get to a graphical prompt for a login. This is a KDE prompt, and I log in as the user I created under KDE, just for grins. THIS time, I actually get a taskbar (last time I didn't get one). Furthermore, clicking on icons actually works, and I don't get those Klauncher errors. What changed? Who knows.

So I insert the CD-ROM labeled source code disk 1, and click on the CD-ROM icon (only KDE shows this, not GNOME). It produces a box saying the device is being mounted, then up comes a window showing the contents of the disc. No clue how any of it is supposed to be installed, but hey, maybe the manual will allude to this sooner or later.

So back to the manual. Under the KDE chapter, they finally show the taskbar icon representing Main Menu. Oops, no such icon on my taskbar. HOWEVER, it turns out this is because the ENTIRE DISPLAY is about 1/2 inch off the screen to the left, so the leftmost icon on the taskbar cannot be seen. Sure enough, that's Main Menu. According to the manual, there's also a "shortcut to shrink panel" to the left of visibility on the display.

Unfortunately, there are no buttons on my monitor to shift the visible display right to get it onto the screen itself. I can only change brightness and contrast. There IS a "hide panel" arrow on the RIGHT end (the visible end) of the taskbar. Clicking on this causes the entire taskbar to shift off the window (NOT the display, just the visible window within the 17" display) to the right. This happens slowly (ALL graphics are slow, as a tradeoff to see them at all), so I have time to see the Main Menu icon before it vanishes. NOTE that Windows 3.1, 95, and 98 and ME all had this display dead nuts centered. I tried them all.

Anyway, I now have a first: A mostly-visible KDE screen complete with mostly-visible taskbar even though I'm not the root. If anyone here knows how to get a KDE window centered on the physical display like every known version of DOS or Windows does, let me know. I didn't know it was even possible to miss the display. This is MUCH better than before I installed with "nofb" and tried to let the Linux Millennium drivers drive a Millennium card, of course. I can see 90% of the screen, undistorted, rather than only 60% with serious distortion. I guess I should be happy.

Next task: To change identity to the other user I created. So I go to the shell, and attempt to login as that user. Login rejected. Oh shit, what case did I use? I try every variation of case and spelling I might have used. I even wrote it down, but what I wrote down doesn't work either. Nothing works. I simply cannot log in as that other user. And I can't log out as the current user either. It just generates an error, and tells me to type "exit". But that's no good, "exit" just exits the shell window and dumps me back in KDE.

So I go to the logout icon and log out entirely. When it asks me to log back in, I enter that second user I created according to what I wrote down, even though that didn't work earlier. But sure enough, at this prompt it works fine. BUT, it produces the GNOME window! I want to be in KDE.

The light begins to dawn. These aren't just graphical protocols, these are entire subsystems, with their own users and maybe even their own file systems and own roots! Gack! I guess a user created under GNOME doesn't exist under KDE. Scary. In any case, I prefer KDE because I can see other drives (the floppy and CD-ROM) which GNOME doesn't seem to know about. So my next task is to create a second user under KDE. But under KDE's User Manager, that second user was there. I just couldn't get to it except under GNOME. Why not? The manuals are silent on this.

Again, I can't use the GNOME shell, "logout" and "login" don't work there. However, I HAVE found a method -- goto the shell, type "switchdesk KDE", get the confirmation that it's been changed, then press the power button and cold start. Ugly as sin, but nothing else seems to work. The several-minute boot process seems excessive overhead just to change users, though. But the shell window under GNOME doesn't let me do this, and none of the options under any of the graphical icons allow it either.

If anyone out there knows how to log out of GNOME, let me know. Cycling the power is damn slow. In any case, after the full several- minute cold boot, I log in as the second user (remember that in the GNOME shell I changed to KDE before I cycled power). Sure enough, I go through the entire KDE installation sequence, then finally reach the KDE desktop and there is NO TASKBAR. Been there before. So I right-click, log out, and log back in as the second user. THIS time, I get a blank screen. No wallpaper, no icons, no taskbar, and no mouse buttons do anything. Sigh. Back to the power button.

THIS time, I get the same login screen, I get the same KDE startup picture, but eventually I get the KDE desktop. And THIS time, it has the taskbar on it! OK, let's hypothesize that I've gone through the multiple-cold-boot process with both users, and now I'm able to switch between them easily. Let's give it a try.

I right click, select logout. I get asked to log back in, and I do so as User1. It starts loading KDE for a while, then clears the screen and asks me to log in a second time. I repeat the same login, and it repeats the same process, and finally gets me back to the KDE desktop. Kewl. Now to switch back. Select logout. Login as USER2. KDE re-initializes, but doesn't take a crap this time, and we reach the KDE desktop. Of course, this desktop is always 1/2 inch off the display, but we see MOST of it.

Great progress! I know how to create a new user in KDE, and with only two reboots I can actually switch to that user. With THREE reboots, I can get a working KDE desktop with taskbar. Of course, this is probably draconian if we're a server, to keep powering down to change gears. But it seems to work and nothing else does. And of course, no version of Windows has ever caused such headaches.

Meanwhile, four more disks came with the distribution, and so far not a single word about how or where to install them or what they're for. Also meanwhile the "nofb" means we're DOG slow with no visible hope of any cure. Tomorrow's task: Try to find some way to install the help, the source code, and the games. Hell, I paid for them, I should be able to use them.

And there may be dozens of Matrox Millennium Linux drivers out there, and maybe one of them will work? One thing about Linux, there is NOBODY to call for support. Find an appropriate newsgroup, explain the problem, and pray. It's free, and you get what you pay for.

For me, this is kind of fun. After all, I don't need to do anything particular with the system, like use it or anything. Otherwise, it's Microsoft in a heartbeat.

-- Flint (flintc@mindspring.com), March 24, 2002.

How To Pronounce Linux

Ever wonder how to pronounce Linux? Ever wonder why so many people pronounce it differently? Well, you can stop wondering.

There are three common pronunciations of Linux. All three are quite acceptable, because everyone knows what is being talked about when you use any of them, and that's all that is important. However, if you are wondering what truly is the "proper" way, it will be explained here.

The only proper pronunciation is the one used by Linus Torvalds himself. The name Linux is a derivative of his name, and thus is pronounced like his name. Linus pronounces his name "Lee-noos", so Linux is properly pronounced "Lee-nooks".

A linguistically acceptable pronunciation is based on the Anglicized pronunciation of Linus, which is "Lie-nus". Hence, an acceptable Anglicized pronunciation of Linux is "Lie-nuks".

However, there is a third common pronunciation of Linux, which is "Lin-icks" (or sometimes "Lin-ucks"). This pronunciation has no basis in reality or linguistic derivatives. It does, however, sound more like "Unix", which is probably the reason it came about. Unfortunately, this incorrect pronunciation is the one most newbies cling to, so when they try to correct us old-timers, we tend to get a little belligerent.

In the end, it is irrelevant. You say to-mah-to, I say to-may-to. Who cares? Either way, it's still a juicy red fruit that tastes good on a hamburger. How you pronounce Linux is far less important than whether you use it or not!

-- Stephen (smpoole7@bellsouth.net), March 24, 2002.

Where I work, when we can finally get it to do anything resembling what Windows does second nature, we call it "Lynnucks". Most of the time, what we call it will turn your face red and your ears blue.

-- Flint (flintc@mindspring.com), March 24, 2002.


I swear if my basketball bracket situation would have been different I would. You can get a pretty good iMac for about $500 or an early G4 for about $800 I think. If for no other reason than to imagine the look on your face when you actually received it. Plus I think you would appreciate the correlation with Linux/Unix/Mac. My experiences with these things comes from an average joe perspective, it's like the car analogy, do I need to know how to work on it or just drive it? Even though I'm no NASCAR driver I can still tell ya that car A drives better than car C, cause car C is loose in the Curves : )

I do look forward to installing Red Hat on a barebones Mac, sounds like fun, though it puzzles me why?

-- capnfun (capnfun1@excite.com), March 24, 2002.

There are two basic problems slowing down this process. The first is that both the KDE and GNOME shells are well off-center on the monitor, so I can't see the "start button". However, now that I know it's there, I can run the mouse off the display and click on it. Up pops a menu and I can read most of it (except the first few characters on each line).

The second problem is that the getting started guide doesn't seem to have been written for the actual software. Menu selections have different names, windows have different displays and selections, and you're left thinking "This is what they probably had in mind."

One quick example. Section 3.9 in the manual, "Shutting down at the Shell Prompt." The directions tell you to open a shell by clicking on the shell icon. Yup, that works. Step 2 says:

"At the shell prompt, type "shutdown -r now" or "shutdown -h now" and enter your user account password in the dialog box that appears. The - h means halt and will shut down the systen; the -r means reboot and will restart the system."

OK, fine. I'm sitting at the shell prompt, so I type "shutdown -h now" as instructed. I'm rewarded with the following message:

bash: shutdown: command not found.

Great. Needless to say, no dialog box appears. The system does not shut down. Typical.

So I do some trial and error, and I learn several things. First, the shutdown command DOES work at the shell prompt if you are root rather than a user, but there is no dialog box or prompt for an account name or password. It just shuts down, plunk. Second, I learn that if I use the undocumented command "reboot", the system shuts down whether I'm root or not.

So let's generalize. If you want to know how Windows works, you read a manual and find out. If you want to know how Linux works, chances are your particular version isn't quite like anyone else's. You try everything you can think of, keep note of what happened, and create your own manual by characterizing the system. You'll only learn a very small fraction of what the system can do, but you'll also learn things nobody else ever knew, so you'll have *secret lore*.

By the way, all of the pre-desktop windows are centered properly. This includes every window during the installation, and the OS selection window seen every boot. Weird...

-- Flint (flintc@mindspring.com), March 24, 2002.


But now we need to parse this a bit. It's obvious that you have three problems: documentation, X is unable to use your video card properly, and your install did NOT put all the needed packages into place.

You bought one of the publisher's editions with a book, did you not? Now that I think about it, none of them worked as advertised for me, either. (Red Hat 7.1 came the closest.) I had problems with the Red Hat distributions included with Linux Bible and Linux Unleashed -- both done by reputable tech houses like Sams.

I also realize now why my engineer friend in Colorado specifically told me to get Mandrake 8.1, and nothing else. I bought these books after I installed Mandrake, at which point I tried the Red Hat stuff out of curiosity. They didn't work as well, but as they were older distributions (7.0 and 7.1), I naively assumed that to be the problem and dismissed it.

And again, I apologize for that. I installed Mandrake, was astonished at how easy it was, became an Evangelist. I should have investigated further.

My Peter Norton's Guide To Linux (a book only, no CD) calls for things that aren't there, too. So you're right, the big problem is in the documentation. While this doesn't excuse your ... erm, fun[g] ... the Linux community is aware of this and has started the Linux Documentation Project just to address it.

(And just for the record, Mandrake includes two manuals and online support in their forums -- where you DO get answers.)

My big fear is that the Linux Evangelists are pushing the system before it's completely ready for the *AVERAGE* user. The *system itself* is fine, but the interaction with an average user leaves a lot to be desired, and I'll admit that.

And I am dismayed and amazed that Red Hat is apparently lagging behind some of the other distributions, if what you report is typical, because Red Hat is the largest distro!

But there is no doubt that your install did NOT go properly if the "shutdown" program (and its man page) isn't there, because it's one of the core packages. That's inexplicable. It should be right there with bash, vi and all the other core programs.

Oh, and one other little point: "wine" is the Windows emulator. Mandrake doesn't install it unless you ask for it, because it's an alpha with a lot of bugs. Another big difference between RH and Mdk.


People like me DO have to worry about how it works, and one thing that has hurt the Mac in tech environments like mine is that it's more difficult to interface to specialized hardware. Plus, worse luck, most of my control software is written for Windoze.

If it wasn't for that, though, I might very well be typing this on a Mac instead of a PC running Linux. :)

-- Stephen (smpoole7@bellsouth.net), March 24, 2002.

More trial and error. What I've found is:

1) If I run Xconfigurator as the root and select a much higher resolution, I can see the entire screen, which is no longer enough off-center to hide the menus. The downside is all text is really teeny, so things are hard to read. Selecting the smallest resolution I can read without eyestrain means I lose the menus off the left side of the screen. Sigh. Well, I have a magnifying glass handy...

2) Unlike Windows, there's no provided easy way to change resolutions. You have to reconfigure, log out, log back in. VERY time consuming.

3) The other 5 CD-ROMs that come with RH 7.2 are mentioned ONLY on the packing list. None of the provided manuals mention them at all. The source code disks (two of them) have files visible in KDE, but no readme, no installation or setup program, no help. The Red Hat documentation disk follows this same format. Maybe you aren't supposed to copy these to your hard drive? I have a suspicion that you should copy them, but the system won't be able to find where you put them until some config file is altered somewhere in some way. Needless to say, not a word of documentation on this.

The StarOffice disk does come with a PDF file explaining setup. As I'm coming to expect by now, this document advises me to go to the installation directory on the CD-ROM, and there is no such directory. There are only directories for languages. This PDF file is itself inside the English subdirectory. Within the nonexistent installation directory, I'm advised to run programs not on the disk anywhere.

Since there aren't any directories under the English directory, I decide to run the first executable program in the English directory. Sure enough, this starts doing an installation. This file is about 93M. There are two other executables in this directory as well. All three have long cryptic names, differing only in a single character. These filenames look kind of like automobile serial numbers, so you can only guess what they might do.

By trial and error, I learn that the one I executed installs two office-type programs, and the other two each install one of them. That was fun. Now to log out, log back in, and see if any new icon appears on the desktop as the installation promised...nope. No change. I wonder where that stuff went? Well, it's visible from the Start menu (if you can read letters 1mm tall, of course).

The final CD-ROM is the games. This one, like StarOffice, comes with a readme file explaining how to install the games. It tells you to execute a file that (ready?) *does not exist* on the disk. Meanwhile the disk has a whole bunch of files the documentation does not mention. Someone really ought to introduce the tech writer to the disk being written about. Alternatively, a common approach is to give the disk to an intelligent novice and see if he can puzzle out how to do anything useful. You can learn a lot that way.

A final note: the eject physical button on the CD-ROM drive does NOT WORK under Linux. If you have a CD-ROM icon, you can right click to get a menu, and left-click on "eject". Otherwise, you can always hit the master power button to regain control of your system.

-- Flint (flintc@mindspring.com), March 24, 2002.


Oh, the shutdown utility is there all right. And the man page describes it just fine. But unless you are the root, bash claims it never heard of shutdown.

The disks I'm using didn't come out of a book, I bought them directly from Red Hat. This is their official distribution. You get 7 disks, an installation guide, a getting started guide, and 30 days of tech support from Red Hat (on the net, not talking to a live person). Of course, the system I'm setting up isn't on the internet at all.

I agree that significant work needs to be done on the documentation. About all that you can rely on right now is that whatever the documentation says will NOT describe your system. Sometimes it's close enough to make a good SWAG, sometimes not. Nothing is more likely to make a new user unhappy than lousy documentation of a system designed from the ground up to be unintuitive.

-- Flint (flintc@mindspring.com), March 24, 2002.


It's setting the permissions too restrictively. I can get to shutdown with any user, because I chose minimal security during install and then increased what I *wanted* to protect once everything was running.

I guess Red Hat is geared to businesses, where you wouldn't want a dozen users to be able to shut everything down at will. But they should certainly give you that choice!

Tell you what: because of all the pain you suffered, when Mandrake 8.2 and KDE 3.0 comes out next month, I'll send you the set when I'm done with it. :)

I feel like I owe you that much ...

What you've described is utterly amazing to me. I had NO IDEA there could be THAT much difference between distributions. Mandrake is a pleasure to use.

To install any software package, I go into Mandrake Config and run the Software Manager. It automatically lists the available packages and installs them with a click or two, much like a standard InstallShield wizard under Windows.

I can also change resolution without restarting, so I don't understand THAT one, either.


-- Stephen (smpoole7@bellsouth.net), March 24, 2002.


One day I'll learn to read more carefully.

OK, so you only have to log out to change resolution. To be fair, I have to do that, too -- the difference is, I'm running a much faster processor (Pentium 550Mhz) and maybe I just didn't notice, because it happened so quickly (a few seconds).

But now, if we're being fair, I have to point out that some video cards require that you restart Windows, too, so I suspect that this depends on the driver and hardware.

Under X, doesn't the Logout dialog offer a "shutdown" option? When I click that wierd-looking circle-with-stick icon on my system, the dialog that I get lets me choose logout, restart or shutdown.

If not, there's another difference between distributions. Amazing. I stand humbled, and I will DEFINITELY be careful what I recommend in the future!!!

By the way, I don't like Gnome. It's a favorite of the Open Source evangelists, but I much prefer KDE. KDE 3.0 is supposed to really nice.

Incidentally, once you get the system ironed out, you'll have to get used to some differences in how the X environment acts. For example, you're expected to use CTRL-C for copy, CTRL-X for cut and CTRL-V for paste. I learned to use SHIFT-DEL and SHIFT-INS way back in the DOS era, and this drove me crazy until I figured it out.[g]

-- Stephen (smpoole7@bellsouth.net), March 24, 2002.


[When I click that wierd-looking circle-with-stick icon on my system, the dialog that I get lets me choose logout, restart or shutdown.]

I'm assuming this is the logout icon on the KDE panel? Also reachable from the main menu icon. When I click on it, up pops a box that says "End KDE Session?"

There is a checkbox labeled "Restore session when logging in next time", and by default it is checked.

Finally, there are two buttons, labeled "logout" and "cancel". Cancel just returns me to KDE. Logout blanks the screen, which is eventually replaced by an X windows login prompt box. There are no reboot or shutdown options in any of these windows.

However, you realize the Start menu (the gear with the K superimposed, now that I can see it) itself leads to an avalanche of programs, utilities, functions, and a cast of thousands. One of these, for example, is called "package manager." Maybe this is similar to your "Software manager"? It says it's a "package installer", whatever that is.

One thing that does not appear to be on the main menu is a shutdown selection. This may simply be because I'm not the root right now.

In any case, I'm going to declare Linux Officially Installed at this point, despite the two source disk and the documentation disk not yet copied to the hard drive. Along with the distribution, I purchased over 1000 pages of other documentation, the Red Hat 7.2 Bible (by Negus), and a Linux programming book (by Wall). Quite possibly I'll osmose enough out of these books to take a much more educated guess about how to install and access those disks. Part of the Linux philosophy seems to be just to throw darts and see what happens. Actually *telling* you would take all the fun out of it.

So now I'll dive into all that other stuff, perchance to learn. Oh boyohboy.

-- Flint (flintc@mindspring.com), March 24, 2002.


Yep, I meant the logout icon. Here's a screenshot of what I get in KDE:

I would suspect that the Package Manager is Red Hat's software manager, yes. Red Hat's packages, called "RPMs," are the standard (even Mandrake uses them). I don't know how easy the Red Hat manager is to use because I've never tried it.

Sounds like you're finally getting there, though.

(We can hope, anyway.)

I'm just disturbed that your video is still ugly. Like I said, I had that problem with RH 7.1, but when I went back to Mandrake, it cleared up.

Just to satisfy my curiosity, what version of KDE do you have?

-- Stephen M. Poole (smpoole7@bellsouth.net), March 24, 2002.


I'm running KDE release 2.2-11

I get a window almost like what you just posted, EXCEPT that the rectangular box of radio buttons isn't in that window. This is true whether I am user or root. Incidentally, we installed RH 7.2 where I work, which we downloaded off the net (we have a T1 line). THAT version produces a window like mine, without any choices other than logout or cancel. But if you select logout, you get put on An X windows screen with a big Red Hat logo, and a window inviting you to log in, reboot, or shutdown. My only choice on this window is to provide a login name. Shutting down is not an option. At this window, I simply press the power button. It takes about 90 seconds to reload KDE, run a shell as root, and issue the shutdown command. That's a lot of time.

-- Flint (flintc@mindspring.com), March 25, 2002.


I just had a brilliant inspiration. I downloaded the latest Matrox Millennium BIOS from their website, along with their flash program. Turns out my video card firmware was 5 years out of date! So I flashed in the new one, and reinstalled Linux by pressing Enter at the boot: prompt.

No problems! The video drivers all work fine now. I should have thought of that earlier.

Once I'm reinstalled fully, I'll experiment with RPM packages.

-- Flint (flintc@mindspring.com), March 25, 2002.


I'm using 2.2.1, which is a slightly later, slightly revised release

(*IF* I understand how those geeks do their release numbers! Shoot, I haven't yet fully figured out what all the colors mean when I do an "ls" at a command prompt![g])

But I do believe that each vendor customizes KDE, too.

By the way, on the video thing -- a growing concern for Linux, FreeDOS and the other "free software" developers is that Microsoft has been quietly urging hardware vendors to drop their "generic" interfaces (such as the VESA INT 10h functions for video) and supply Windows(only) drivers instead. This makes it very difficult for these programmers to support some hardware.

Fortunately, either your new BIOS apparently still has the VESA stuff, or (given that it's an older card), Linux includes a driver that *expected* the new BIOS.

Who the heck knows? I sure don't. :)

Mandrake has a generic mouse driver that actually asks you to roll the thumbwheel (if you have one) during installation. You then click the buttons. It then "learns" how your mouse "acts" so that it can use it!

They solved it the old-fashioned way. :)

-- Stephen (smpoole7@bellsouth.net), March 25, 2002.

As expected, this is totally frustrating. Source code CD1 has a subdirectory of RPM packages. There are 360 of these, of which I desire to install all 360. Clicking on one brings up the package manager, which has two panels. The left panel shows a tree structure, and the right panel describes the package I selected. Up pops another window, asking if I want to install ONE package. There is a subwindow titled "packages" showing the ONE package I clicked on, with lots of room for more. Dragging and dropping doesn't work. You can't type in a package name. There doesn't seem to be any way to install more than one single package at a time.

So OK, I click on "Install" and get an error message box. The entire contents of this box are a title bar saying error, a message saying error, and the name of the package. And an OK button. No help, no clue what the error is. So I click on OK, and it says "installing", and the package shows up in the left panel, on the tree. Did it install properly? What was the error? Is there any help?

The left panel has some click boxes under it that say (among other choices) "Install marked packages". All right! How do I mark packages for installation? I can go to the CD-ROM window and do a select-all, and all 360 RPM icons turn green. Good start. I click on "install marked" and nothing happens. I try to drag and drop the whole schmeer, but it won't move. Click anywhere else on the entire screen, and the green shading vanishes.

OK, let's go back to 360 separate installs. Sigh. Each one produces (1) Its own package installer window; (2) Its own install 1 package window; (3) Its own error message. Very soon, my screen is layered 10 deep with superfluous windows. Can this really be what they intend?

After clicking OK to half a dozen or 10 error messages and watching installations, I notice something peculiar. The red N that appeared in the tree of the individual install window for each package changes to something that looks like a couple pages of paper with a red X over them. Does this mean they didn't install after all? Documentation? Are you kidding?

So I decide to reduce the screen resolution so I can read better (it's still really teeny). I run a root shell, type Xconfigurator, and get a segment fault! Type for Ye Olde Power Button again.

Help! If anyone knows how to install packages, let me know. I have been told that I MUST install them according to the specific directions the package manager alone can decipher, or else every dependency on every tree structure, header file, linkage required by make, and everything else will be hosed beyond all recognition.

Meanwhile, I'll see if a cold boot and another trip through Xconfigurator will clear up the segment fault problem. Sure enough, it does. By trial and error (and many reboots) I learn that my video problems really are no better in KDE than ever. 800x600 and 1280x1024 fit on the monitor, but the two resolutions between them (what I want, of course) are off the left side of the monitor, and serious hourglassed as well. I guess we live with teeny tiny.

So I know it's not the video card now. And the package manager remains a mystery. The installation instructions are cryptic, and my best guesses (and every other guesses) are all failures.

AHA! Fuggidabout this censored KDE graphical environment. All you need is the single shell command line

rpm -i /mnt/cdrom/subdirectory/*.rpm


-- Flint (flintc@mindspring.com), March 25, 2002.


Don't slap me if I'm telling you what you already know or have already figured out, but to shut down cleanly, try this:

If you're in X, start a terminal window.

At the prompt, enter "su" to become the root/superuser. You'll have to enter the password.

Once you're logged in as root, enter "shutdown -h now" or "shutdown -r now" to halt or reboot.

See if that doesn't work.

Again, you may have already figured this out. If not, at least you won't have to crash it everytime you want to shut down! :)

-- Stephen (smpoole7@bellsouth.net), March 25, 2002.

Thanks, Stephen. That works fine. Im starting to figure out that it really doesn't help much to ask someone running the "same" software how to do things. I've asked quite a few now, and I've mentioned some of the responses. You get a logout window I don't get. Someone else gets my logout window, but this gets them to a login screen with a shutdown option I don't get.

Once again, it's a different world from Windows. With Windows, someone familiar with the system can say "You will see this, click on that, up comes this..." With Linux, they have to say, well, your system probably has something that provides the functional equivalent of what mine does, unless it doesn't...

And the shell command line options are a world apart, fer shure. Grep all by itself is a language. So is awk. Even the DOS "dir" has been turned into ls, which has about a hundred options none of which do what you really want. Let's say you want all of the files with a .c extension on your drive. In DOS, piece of cake. cd\ to get to the root, and do

DIR /s *.c

I have so far spent three hours trying to manufacture the equivalent to that command using ls, and find, and grep, and pipes, and regular expressions, and script commands. So far, the closest I have come is to find all files with an extension that *begins* with c, so that filename.chargeAccount (for example) qualifies. My current approximation is:

find / | grep "\.c"

(By the way, cd\ doesn't work either. You need a space).

-- Flint (flintc@mindspring.com), March 26, 2002.


Well, at least the command line should be standardized. The major differences are in the various releases of KDE, and more importantly, which enhancements a given vendor has tacked onto it.

I printed out the man page for ls and spent a good evening learning it. It does have some oddities, I'll grant you that.

I can get it do something like what you want ("ls c*"), but it automatically recurses into subdirectories, which isn't necessarily what I want. There's supposedly some configuration options that you can set up for defaults; mine are (big surprise!) obviously different from yours.[g]

(I KNOW you're shocked.)

Of course, serious Unix heads would scold us for even cursing it, because they *like* doing things like "ls" piped into "grep" piped into "rm" (remove) ... where for me, the very thought of executing a command line that could touch and possibly delete files all over my system makes me itch. :)

That's the only thing I can say in it's defense, I guess -- that it (and the other command-line stuff) were created so that you COULD execute a single command line that rules the world, launches missiles and feeds the starving babies overseas in one operation.

-- Stephen (smpoole7@bellsouth.net), March 26, 2002.

Oops ... you wanted "*.c". Yep, that one IS a little different. I've had trouble with that one, too. Linux doesn't LOOK at extensions the same way that we do.

-- Stephen (smpoole7@bellsouth.net), March 26, 2002.


dir /s *.c

can be simulated in Linux this way:

find / | grep "\.c\>"

Intuitive, ain't it? Of course, you still get a lot of "permission denied" messages if you're not superuser. However, if you add this little enhancement:

find / | frep "\.c\>">cfiles

then the files you find are redirected to file cfiles, while the permission denied messages go to stdout, your console, and won't be in your cfiles file. Then just look at the file.

Another wonderful thing. Not only are these regular expression thingies devious as hell, but Linux has never heard of an "are you sure?" message. So if there is any possibility that what you're doing might be destructive, don't do it. Hint: there is *always* some possibility it might be destructive, you just didn't remember subfuction 75, variation 3, which could have been used to prevent the nonobvious side effects except in certain exceptional cases mentioned cryptically in Appendix H...

-- Flint (flintc@mindspring.com), March 26, 2002.

You two crowdpleasers are describing the sort of thing which generated murderous feelings in me beforeI got terminal geek fatigue. The only thing that will get me to stray from good old Windows 98 is really good speech recognition. That will get me to sit up and take notice.

-- Peter Errington (petere7@starpower.net), March 26, 2002.


I wish I still had W98. My CD developed a severe case of feets and disappeared. I bought Windows ME as an upgrade and am trying not to gag. No wonder Microsoft moved on to the NT architecture; the Win386 model had apparently been tweaked as far as it could go -- as witness WinME.


OK, it's official. I'm not sure how you'd get to this specific page, but when I browse to Download.com (part of C/Net), it recognizes my OS and gives me the default Linux page. I happened to notice the user ratings on the various Linux downloads near the bottom.

Mandrake (which I'm using) has a 96% approval rating. (Ninety six percent!!)

Red Hat and Slackware have 34% approval ratings.

Debian/GNU has 23%.

I never would have dreamed it. I thought the distributions were more alike than that, but apparently, you ain't the ONLY one complaining!

I hate to suggest this after all the fun you've had, but you really ought to go to CompUSA and pick up Mandrake 8.1, or wait until next month and I'll send you 8.2 when I'm done with it. (I was serious about that, by the way.)

-- Stephen (smpoole7@bellsouth.net), March 26, 2002.


I sympathize with you totally. I have Win 98 on my desktop, long may it live. I have Me on my laptop, my Internet machine, and I'm not thrilled to say the least.

-- Peter Errington (petere7@starpower.net), March 27, 2002.


Of all the '386 architecture versions that I've tried, 98 was tops, hands down. It was stable, quick, included lots of goodies (like Microsoft Fax, which has been removed from WinME!) and was just a pleasure to operate. Setting up a home network was laughably simple, too. It also ran all of my old DOS stuff flawlessly -- important in my line of work.

I miss it sometimes. :(

-- Stephen (smpoole7@bellsouth.net), March 27, 2002.

Sigh. I was really looking forward to divorcing Bill Gates, but I think I might wait a while until y'all have the bugs worked out. Can Flint forward that software on to ME when he's done, Stephen?

-- Anita (Anita_S3@hotmail.com), March 27, 2002.

This reminds me of going from one mainframe to another when I worked at Boeing. The names would be different, the paths twist different ways to get to where you wanted to be, you would have to figure out what name this particular group of manufacturers and their software guru's had decided to give a function. That's where I would have my most fun, read the "manuals" (like reading a forein language) and sit down and try to make them function with a hit or miss method. As soon as I got a few under my belt I would make them into macro's when added to other macro's eventually turned my efforts into some sembalance of an operating system. I could never understand why the engineers would take all that time ro write out the same line of "code" every time they needed it when they could bundle them within other bundles like I did until all I had to do was start my programs and let the computer do all of the repetitive work. I used to call what I did "rooms within rooms", microsoft calls it windows.

Sounds like fun what you are doing, maybe I should get a copy and play with it to see if I have the ability to do it. I don't think most people realise all of work being performed in the back ground when a windows function is performed.They have made it user friendly, say drag and drop by dragging the mouse~~~could be hundreds of lines of code involved without the user having to give it a thought.

-- Cherri (jessam5@home.com), March 27, 2002.


Good analogy. That's obviously part of what's going on here. But there is also a problem with the documentation, too -- even under Mandrake, which is apparently an order of magnitude easier than Red Hat. There have been a few times for me when the book would describe something that simply wasn't there. A trip to their Web site and a little searching would turn up, "oh, we changed that. Sorry."


I'm trying to be fair to Red Hat; they're obviously targeting businesses more than homes ('cuz that's where the money is). Not to mention the fact that they're based in RTC in NC, my original stomping grounds!

But when I saw those approval ratings over at download.com, that sort of sealed what I've been suspecting. I was *stunned* when Flint began reporting all of his problems.

Does Mandrake have problems? Yeah, some. But nothing like what Flint is relating! For example, the scroller on my mouse will very occasionally stop working when I'm browsing the Web -- probably due to a buggy Java VM or Javascript interpreter in Konqueror.

Mandrake 8.1 is very, very good. The KDE interface is point and click, VERY easy and fun to use. In fact, I rarely boot into Windows anymore. I just start up and let it fly on into Linux, the default.

Mandrake has apparently done a ton of research on helping people like me who are migrating from Windows to Linux. Red Hat, on the other hand, must be targeting Unixheads and college students.

I am really looking forward to Mandrake 8.2 and KDE 3.0. And yah, if you want to try it, maybe Flint will forward the stuff. :)

-- Stephen (smpoole7@bellsouth.net), March 27, 2002.

To be fair, a lot of the problems I've had have been due to video drivers not working properly. I'd have saved hours of confusion if I had had any of knowing that by far the most important panel icon (the Main Menu, fer pete's sake!) was off the edge of the screen and couldn't be seen. It just so happened that the second icon was lined up just right, so nothing looked funky.

The rest of the problems fall into two general categories -- the documentation generally not describing things properly, and my own lack of familiarity with UNIX.

Some things seem easier to deal with. For example, I wrote a simple HTML file in both Windows and Linux. It didn't do much, just created a sample title, a sample header1, header2, some text, a couple of links to named labels elsewhere in the file. Now to run it in IE 6.0 and Konquerer respectively and see what happens.

In both environments, it shows up as an HTML icon. Click on it, sure enough, mostly it works, some things don't. Time to edit it. Right click on the icon. Linux provides a menu with an "open with" selection, and I select gedit. Up pops a gedit window with the source. This is a nice editor! Windows provides a similar window, with an "Edit" selection. Click edit, and get thrown into Microsoft Word! Word *executes* the html, and you have to select "view source" within word to see the original file. Ugly!

OK, how do you change the "Edit" button to associate it with notepad instead of word? Not easily! If you've got Win98, you select view- >folder options. In ME, you go to control panel->folder options (they moved it). Then you select "file types". Scroll down until you find HTM or HTML, and click on it. It says "opens with Internet Expolorer", and there's a change button. DO NOT click on the change button. Unlike Linux, "opening" the file doesn't mean opening the file, it means *running* the file. If you select change and open with notepad, you can't run html files anymore!

Instead, you click the "advanced" button, select "edit" from the scroll window, then click the "edit" *button*, then click "browse", find /windows/notepad, select OK, and you're done! Now when you right click on an HTML icon, you can select OPEN and *run* the file, or you can select EDIT and *edit* the file.

So anyway, today I spent the whole day working with HTML files, creating frames and forms and java scripts. I'm new at this, and I don't want to waste time battling against my tools. Needless to say, I spent the day in Linux. Kewl! Make a change in the gedit window, save without exiting, click the refresh button in Konquerer, and see your changes instantly. Sure, you can do this in Windows, but there it's an unnatural act. In Linux, it's hard to avoid.

Still, the shell must be learned, and that's a long, steep curve. Unix people have spent 30 years dreaming up utilities that combine great power with maximally unintuitive jawbreaker command lines, complete with pitfalls everywhere you look.

Incidentally, grep seems to think "\.c\>" and "\.c$" are synonyms. Is this right?

-- Flint (flintc@mindspring.com), March 27, 2002.


I can't say for sure on the equivalencies of the two commands. I'm not in Linux at the moment; in fact, I'm down at one of our stations setting up an Internet proxy for our office network. :)

Ask me how *MY* day went. I will *NEVER* buy a Compaq. Period, end of discussion. They're fine as long as you run them as delivered from the factory; but if you EVER change anything, you can throw them away.

This little Deskpro conquered my beloved Mandrake. Defeated it. I managed to get it to install, but -- tada! -- video problems, only in my case, no matter what, I got 640x480x256, which meant that all windows were off the side and bottom of the screen, so you couldn't click the "OK" buttons! (You're familiar with that.[g])

Amazing how MY experience just duplicated yours, but in this case, I knew the problem: it was the @#$##@ computer. I know this because I had all sorts of conflicts under every version of Windows that I tried, too (I was getting desperate). It's the computer.

All day. What should have taken an hour or two has taken ALL DAY and I'm still working on it. I finally got smart and went home for a while; I borrowed a spare computer from my apartment nad have just finished putting Windows on it. I'll loan it to the company until we can get something else (ANYTHING but a Compaq!) in here.


I haven't tried GEdit (I use KEdit); I'll give it a spin.

-- Stephen (smpoole7@bellsouth.net), March 27, 2002.


Sounds like a nonstandard video graphics chip. Compaq today is kind of a "whatever Taiwan produces cheapest this week" sort of company. So you might have an SiS chipset, with integrated video. SiS is famous for not-quite-compatible video hardware, kind of like the early NVidia stuff was. And in that case, you've hit a common problem. If the video driver didn't come with the unit, it probably won't work. It was probably custom-written for Compaq, and ONLY for the Windows version they chose to distribute with that model.

Not that it makes life any easier, but it's not like a generic Matrox card either.

I'm currently typing this on a Compaq, running an AMD 1GHz Athlon and a Via chipset. The video is an NVidia GeForce2 MX, which is another standard. I wouldn't be shy about any strange installations on this unit either. But when you get into laptops for example, all bets are off.

(My point here is that the problem is NOT the computer. It's the software. Nonavailability of drivers is kind of a gray area, and we've been known to reject perfectly good hardware for that reason.)

-- Flint (flintc@mindspring.com), March 27, 2002.


I was giving you the abbreviated version. Neither Windows nor Mandrake could completely sort out the PCI slots or the network cards (older 3COMs and Intels, the drivers for which have been available for years), either. So yes, I guess you can say that it's ultimately the software, but given that the software works fine on 99% of everything else I've tried, I point fingers at the 1%.

Yeah, it has an S3 video chip which is known to have problems. Unfortunately, it's arc-welded onto the motherboard and there's no way to disable it so that I can use a different video card. Nor will these machines let you into the BIOS setup; they are convinced that they can analyze and update the configuration without any assistance from mere mortals.

Of course, when it happens to get something wrong, you get to sit and stare at a blank boot screen for a couple of minutes while it ponders the fact that the floppy drive just WON'T WORK. Then it disables it without further ceremony and says, "Press F1 to continue." But I need the floppy to boot, since it can't boot onto the CD ROM (there's no way to set THAT, either)!

So, imagine MY fun: I'd try a different NIC or a different version of Windows, whatever. I had to wait several minutes to see if it had worked. Oops, that killed something else! I'd try to shutdown ... won't work, so I get to look forward to running ScanDisk when I finally get it to boot again ....

Over and over again, all day long. Whimper.

Compaq not only uses whatever's on sale this week, they're also notorious for proprietary BIOS code which is then extended by software loaded during the OS boot. Now, to be fair, these are older machines (200mhz Pentiums), and maybe the latest disks no longer include drivers for this stuff. Who knows?

(And to be even more fair, even Compaq finally figured out that people might really NEED to get into BIOS Setup; the relatively-new Prosignia that I'm typing this on WILL at least let you do that.)

I've heard that HP and Dell are afflicted by the same disease, though perhaps not as seriously.

Gimme a white-box clone with off-the-shelf hardware any day of the week.

-- Stephen (smpoole7@bellsouth.net), March 28, 2002.

Although, while I'm on a roll here, I'll report the fun that I had with the Prosignia. Like many older Windows installations, it happened to lose a driver one day. Who knows why; it happens. The file was corrupt.

I looked at the Compaq CDs that came with it -- and they have their own proprietary OS Recovery Disk! There's no standard, straight-up Windows 95 or 98 CD in the kit; it's a specialized package of smished and encrypted stuff that rebuilds the original installation.

But that's not the best part! The recovery CD WIPES THE HARD DRIVE! That's how it "recovers" your system: it does an FDISK /MBR, formats the hard drive, then reinstalls the entire system as it left the factory.

Of course, if you HAVE added or changed any hardware, it misses that. The OS tries to boot with the wrong drivers and you get chaos.

In fact, that little scenario is what prompted me to go buy Win98, which was no longer available, so I had to buy ME.

You But that's not the best part: the best part is, when you insert the Recovery Disk

-- Stephen (smpoole7@bellsouth.net), March 28, 2002.

OK, I'm gibbering now.

It's time for bed.

Remember, computers make our lives simpler.

-- Stephen (smpoole7@bellsouth.net), March 28, 2002.


I understand what you're going through, trust me. Here are some observations, at random:

1) Sticking a video card into a slot (PCI, ISA, whatever) *ABSOLUTELY MUST* override any video controller on the motherboard. If it does not, the unit will fail the Windows Hardware Compatibility Test, and Microsoft WILL NOT permit Windows to be shipped on that unit. Period. The penalty for violating this is severe. But this should never happen, since the original Plug and Play specification required it in the priority scheme. I personally have never heard of a system where you could stick in a video card into a slot and the system wouldn't act as though the motherboard video didn't exist. I'm amazed (and if this is really true, Compaq is in Deep Shit.)

2) All systems I've heard of have a "back door" method of getting into CMOS setup, although some manufacturers (HP for one) "dumbs down" that setup to nearly worthless. Nonetheless, CMOS setup must be accessible to do some fairly common things like enable and disable local parallel and serial ports, select the boot device, select parallel port mode (standard, EPP, ECP etc.), enable and specify some power management parameters, etc.

3) Booting to nonstandard devices (anything other than hard drive or floppy, like CDROM or USB or a network) does require special custom BIOS code. In the days of the 200MHz CPU's, these were more the exception than the rule. The ability to change the boot order priority is also fairly recent, because the protocol (the BIOS Boot Specification) is fairly recent. Before that time, any BIOS that let you move the order around had to custom-craft some method. This wasn't purely a BIOS issue, because in order to have a boot order, the system needs to try device A, then B, then C etc. But many add-in boot devices (network cards with boot ROMs, SCSI cards, silicon disks and the like) *did not return* if the boot failed. They just kept trying forever, so the BIOS could never get control back to try the next device in line.

4) The recovery CD problem is a straight licensing issue. We have to deal with this all the time. It seems that the licence for Windows that you purchased for that unit was intended for that unit alone. Microsoft does NOT (not since Windows 3.1, anyway) permit a unit to be shipped with a genuine standalone full-featured Windows, that the buyer of a given computer could then install on every computer in his shop! Indeed, some of those recovery CDROMs won't install on anything but the exact disk architecture -- it's a track-copy. What we do is use a standard Windows, and throw those included "recovery" disks away.

5) Generally, you can just hit a key and skip scandisk for what you're doing. It's not like you were running a bunch of cached threads or anything. Scandisk can take forever on these larger drives.

About 1/4 of my department was involved in designing and developing computers, and the other 3/4 was involved in doing configuration and compatibility testing -- trying them out with every available type of add-in card, all Windows versions, all driver options, all possible boot devices, every CMOS setup permutation, and the like. It took about as long to do all this testing as it took to design and develop and build the unit in the first place. Sometimes longer, depending on how many problems turned up. But now, with the economic downturn, we have laid off that 3/4 of our department. Testing has been transferred to the customer. Gotta stay competitive with our competition, who all did the same thing...

-- Flint (flintc@mindspring.com), March 30, 2002.


Well, now that I've calmed down ... I'm trying to be fair; I said these were older machines. Maybe that's not true of the newer ones. (I noted that the newer Prosignia WOULD let you get into setup, for example.)

To give you an idea, these do NOT have an AGP socket. I've never heard of that being part of *Windows* hardware certification, either; that must be something relatively recent.

I have a regular, "generic" Win95 OSR2 CD here that's marked, "for sale with a new machine only." I got it with a clone a few years ago. I also had a generic Windows 98 CD with a machine that I just shipped back to Engineering in Denver (and naturally, the CD went with it).

I knew about cancelling ScanDisk, by the way ... my problem is, I'm a multitasker. I'll be doing three things at once and it's a pain to have to sit there waiting for ScanDisk to start so that I can stop it.

But I'm whining now. I admit it. :)

-- Stephen (smpoole7@bellsouth.net), March 30, 2002.


I'm not quite following this. Are you saying you have seen a system with an S3 video graphics controller soldered on the motherboard, AND an AGP socket? This strikes me as unlikely, for cost reasons if nothing else. Some chipsets support an AGP bus, some do not. But why go to the expense of putting a video chip on the board, and ALSO the expense of populating the AGP socket and associated hardware? That doesn't make sense. AGP is for video only.

But let's say you have such a board, and you put a video card in a PCI slot, and an AGP video card in the AGP slot. Now you have *three* video controllers. The PCI sequence required by PnP (and by Windows) is that the PCI video will be honored, and the other two ignored. Pull that one out, and the AGP will be honored. The onboard S3 chip is the last resort. This (as I said) is a WHCT requirement. I've never seen this sequence violated.

Some OEMs do distribute a more portable Windows system, but Microsoft doesn't like it. I know that Compaq and HP do not. (You understand, I have access to every Windows version there is, so I never paid much attention. Not my problem, right?) What I don't understand is, if you had a good Win98 CD, why didn't you just clone it? Then write the magic 5-letter code group sequence on the disk. That's how mine are, anyway.

Incidentally, I have my development environment set up, and I'm now successfully compiling gcc programs. I haven't tried to rebuild the system, and I doubt I could.

(As a footnote, when you're done with that Mandrake stuff, why not just hand-carry it up here? We're only a couple hours apart, if that)

-- Flint (flintc@mindspring.com), March 30, 2002.

(As a footnote, when you're done with that Mandrake stuff, why not just hand-carry it up here? We're only a couple hours apart, if that)

That'll work. I haven't been up that way in over a year, and I need a change of scenery. I'm still not sure when 8.2 is coming out -- I think they're waiting for the "golden" release of KDE 3.0 -- but once I get it, that's what I'll do.

By the way ... this is a certified forehead-slapping "well, DUH!" I can't believe I haven't mentioned the HOW-TO documentation. Mandrake includes it, anyway; you can also find it on the Web at ftp://sunsite.unc.edu/pub/Linux/docs/HOWTO/. Look for the index file (HOWTO-INDEX).

It's all easy-to-read and print HTML, and it's GOOD. I'm going over the gateway how-to now, as a matter of fact. :)

-- Stephen (smpoole7@bellsouth.net), March 31, 2002.

Oops ... local link: on my system, the how-to docs are in /usr/share/doc/HOWTO.

Look there first, if ungood, then do a search on HOWTO-INDEX; that *should* be a unique filename that's easy to find.

-- Stephen (smpoole7@bellsouth.net), March 31, 2002.

Unisys, Microsoft to launch anti-Unix ads

-- (here@we.go), March 31, 2002.

I can get as far as /usr/share/doc and there I stop. There is no subdirectory under doc (or file in doc either) called HOWTO anything. A search from the root (find / | grep "HOWTO*.*") produces a grand total of two directories on the system containing HOWTO files. There is no such file on the system as HOWTO-INDEX. There is a file called HOWTO.html. This is in the /usr/share/doc/ipchains1.3.10 directory, and gives directions for building and installing Linux firewalling chains (whatever they are). A few (3 or 4) other subdirectories have HOWTO files.

Also, I find something called HOWTO.sgml in the /usr/src/redhat/SOURCES directory. I don't know how to deal with sgml files. I opened it with a text editor and it looks like an html file, but I can't open it as one. In any case, it's just a copy of the one I saw above, directions on ipchain firewalling.

Of course, I still don't know how to search the entire system for a file of a given name. I'm using find / | grep "filename" but I don't know if that's what I should be using. And I still get a ton of "permission denied" messages. For me, this OS still seems like a giant game, requiring obscure incantations to do the simplest things. Hasn't Peter Norton produced a utility yet that makes the filing system accessible?

-- Flint (flintc@mindspring.com), March 31, 2002.


By now, you're probably tired of me being amazed at what Red Hat doesn't include, so I won't comment on that -- save to point out that Mandrake includes the HOWTO subdirectory by default.

You can find the main body of how-tos online at http://www.linuxdoc.org/HOWTO/HOWTO-INDEX/categories.html

The "mini" how-tos are at http://www.linuxdoc.org/HOWTO/HOWTO-INDEX/mini.html

I can't figure out how to use command-prompt "find," either. Maybe I'm just not holding my mouth right. At any rate, I go into the Konqueror browser in KDE and use the "find" tool, which works about like Windows Explorer's. It's a bit slower, but it accepts the usual wildcards and does the trick for me.

Hey! Maybe there's a "find" howto! But how do I find it so I can find out how to use "find?!?" :)

-- Stephen (smpoole7@bellsouth.net), March 31, 2002.

As a test, I went into the Konquerer browser and ran their find utility. I gave it the filename to find in the named: box, and the exact full path in the look in: box. I asked for a known filename, that I see with ls. I told it to ignore case.

It found a total of NO files. Hey, I'm LOOKING at the file I asked it to find. It's right there. The browser below the FIND window shows an icon for every file in the directory I chose in the "look in:" box. I picked on of them. Nope, tools-->find doesn't see it. Wonderful tool.

-- Flint (flintc@mindspring.com), March 31, 2002.


I think it's time for us to use the scientific method to determine why your installation doesn't work, when mine does.

The only rational conclusion I can reach is that your system is possessed. :)

You must burn it at the stake and start over.

-- Stephen (smpoole7@bellsouth.net), March 31, 2002.


I'm suspecting egregious pilot error here. How can a find utility not find what it's looking straight at, unless I didn't ask it nice enough? I seriously doubt that whoever wrote Konquerer went through the exhaustive usability testing Windows did, where ignoramuses like me were plunked down without any instructions and given a list of simple tasks to accomplish. Much like finding a file that's right there with a find utility. If the subjects could not figure it out, Microsoft had sense enough to blame the software and not the subjects. Konquerer (and KDE) have a ways to go yet.

-- Flint (flintc@mindspring.com), March 31, 2002.


My point was, my "find" works just fine. I use the same syntax that I'm used to in Windows' Explorer.

You've spooked me so badly I just checked it again to be sure; I entered "gimp*" as the search object and got a box filled with "gimp" filenames.

I will warn that it doesn't give you any kind of feedback, such as an hourglass cursor or other indicator that it's working. On a large drive, it can take several minutes to complete the search. I hope they've addressed this for KDE 3.0, too.

For that matter, Konqueror the Web browser doesn't always give meaningful feedback of where's it at. I have to watch the little spinning "cog" image in the upper right corner.

-- Stephen (smpoole7@bellsouth.net), March 31, 2002.

Well, OK, the little spinning "cog" works in the "find" dialog, too. Never noticed that before.

-- Stephen (smpoole7@bellsouth.net), March 31, 2002.


I figured out the problem. It's *case sensitive*! dirty rotten crummy.....

-- Flint (flintc@mindspring.com), April 01, 2002.


Don't feel bad. I'm still getting used to that one myself. :)

For 'zample, it's Xconfigurator, not xconfigurator or XConfigurator ... . ...

Ah, the joys of Unix/Linux.

By the way, Mandrake is reporting that 8.2 has been released. They must not be planning to wait for KDE 3. I'll snarf a copy as soon as I can.

-- Stephen M. Poole (smpoole7@bellsouth.net), April 01, 2002.


(If you're still following this thread, it has gotten kinda large ...)

Discovered this in the how-to's: if your resolution isn't high enough to display the entire window, you can move the pointer anywhere over the window, hold the ALT key and the left mouse button, and move it as you wish. This makes those "hidden," off-screen buttons a bit easier to get to.

It's still annoying. If there's anything about X in general that reeks of not ready for prime time, it's that. I can't believe they haven't realized that not everyone has a 19" monitor at 1600x1200 resolution.

-- Stephen M. Poole (smpoole7@bellsouth.net), April 03, 2002.


I tried that trick. It moves the top window around just as though you left-clicked in the title bar and dragged it that way. This trick has nothing to do with rgb gun firing timings on the horizontal retrace -- it doesn't seem to operate at that level.

-- Flint (flintc@mindspring.com), April 03, 2002.

Moderation questions? read the FAQ