full text indexing set up

greenspun.com : LUSENET : SQL Server Database Administration : One Thread

Hello all, we are in the process of setting of full text indexing for some of the tables in our OLTP database. To start with- I have created unique single columns indexes in the required tables. I have defined catalog and added the needed tables and column names to the catalog. I populated the index (started it and waited for few hours). After few hours I see that there are few thousand items populated in the catalog. Everything looks fine. But when i try to query the full-text indexed columns with CONTAINS clause, I get this wierd error,

"Search on full-text catalog '%ls' for database ID %d, table ID %d with search condition '%ls' failed with unknown result (%x)."

The same query work fine using "like". I looked at the documentation, I did not find any help or hint to as why this error occurs. Can somebody please help me....?


Nilesh Sawale

-- Anonymous, October 30, 2001


After some searching over microsoft msg boards I found out that this is mostly caused by the incorrect installations of full-text, ie. you need to install and then uninstall the latest SPs. The sad part of the story is we have done the exact thing for my SQL Server 7 SP3 devlpment database and still get the same error. Any ideas...?


-- Anonymous, October 30, 2001

OOps I meant "uninstall and install SP3" and not the other way..!

-- Anonymous, October 30, 2001


Another possibility is that the password for the "Microsoft Search Service" account has been changed using the Control Panel instead of SQL Enterprise Manager.

Good Luck,


-- Anonymous, November 02, 2001

Moderation questions? read the FAQ