Frozen Film Advance : LUSENET : MINOLTA USERS PAGE : One Thread

I have a Minolta X-370n camera. The last time I used it to take photos it worked just fine, no hint of a problem. The next time I went to use it, I could not advance the film. The advance lever is in the locked position (as usual after advancing the film)and will not move forward. Any help is appreciated.

-- Phillip W. Daniel Sr. (, May 29, 2001


I have the same problem, if you find the answerr, please let me know.

-- A Ferguson (, August 23, 2002.

It sounds like the dreaded cap gone south problem. Have the cap replaced and the advance will proably work again. I have replaced these caps myself. some problems are the viewfinder will ligth up but when you press the shutter button the viewfinder lights go out, I have a minolta x-7a and the film wouldn't advance, I replaced the cap and bingo it worked like a champ. If you have had had camera for more than 5 years or have had it stored for a long time, then its time to replace the cap. I would suggest to replace with a higher rated cap IE.....4v 220uf to 6.3v 220uf, it won't hurt anything as long as the rating is above the suggested rating. I have done this and have not had a single problem with my x-7a or my x-700. Hope this helps someone out!!

-- Starbuck (, November 01, 2002.

Moderation questions? read the FAQ