network error during the initialization of the provider in DTS : LUSENET : SQL Server Database Administration : One Thread

Hello Erik,

I was trying to export data from one MSSQL Server 7 under NT Server 4 to another MSSQL Server 7 under NT Server 4, transferring both the objects and the data with the DTS wizard. The servers are separated by a firewall, on which the port is properly opened. I set up the respective client and network utilities and yesterday it worked just fine.

BUT, after that we restarted the destination server, and it will not work any more!

We have not changed anything on the Firewall, on the source or on the destination server.

I checked:

- on the source server:

+ that the client configuration is properly configured for the destination server with the TCP/IP protocol - with an alias for the destination server and the proper IP address and port (1433);

+ that RPC calls are allowed (though I am not sure it's necessary in this case)

+ that the SQL Server, SQL Agent and MTC services are running.

- on the destination server:

+ in the server network utility both multiprotocol and TCP/IP have been set up on port 1433, with the correct proxy address (for that matter I tried both with the internal and the external one). It DID give me in the log (c:\mssql7\log\errorlog) the 17826 error after the restart - as described in "Q160871 - INF: Listening on Multi-Protocol Fails on Startup", even though only for v.6.5, but anyway I removed all the network library configurations but that of "named pipes", so this error disappeared. I added then multiprotocol and TCP/IP back again manually.

+ that RPC calls are allowed

+ that the SQL Server, SQL Agent and MTC services are running.

+ I started one by one all the all the services left at manual, still to no avail :(

- on the Firewall (with TCPDUMP) that the source server really tries to send packets to port 1433 of the destination server

Finally, I end up with the error: Error Source: Microsoft OLE DB Provider for SQL Server Error Description: [DBMSSOCN] General network error. Check your network documentation. Content: Error during the initialization of the provider.

PLEASE, do you have any suggestions?

Thanks in advance for your time!

Alma Prahova

-- Anonymous, May 09, 2001



My research in the microsoft.public.sqlserver.* newsgroups finds that one cause of the [DBMSSOCN] General network error is if the servers and client involved in creating and running the DTS transfer job do not have the same service pack installed. It is worth checking that the two servers and the client from which you are running are all at SQL Server service pack 3. You can download service pack 3 at

If you happen to be running SQL Server 2000 client tools, it might be worthwhile to run the DTS from a SQL Server 7 machine instead.

Good Luck,


-- Anonymous, May 11, 2001

Moderation questions? read the FAQ