SQL 7 Assertion Failed!

greenspun.com : LUSENET : SQL Server Database Administration : One Thread

I installed SQL 7 successfully on my computer. I'm having an error with SQL 7 when trying to enter "NEW SQL SERVER REGISTRATION". I will go through the process of entering in the needed information into the wizard, but when I get to the last screen and press the "FINISH" button I get the following error:

---------------------- Assertion Failed! Program C;\WINDOWS\MMC.EXE File:../src/sqlsspi.c Line 120

Expression Count

Then it tells me to check out the documentation for Visual C++ for info on asserts. ----------------------

IF I CLICK "IGNORE" I get: "Memory Allocation Failure|Cannot generate SSPI context"

IF I CLICK "RETRY" I get: "Code execution exception:EXCEPTION BREAKPOINT"

It also asks me to check my SQL server registration properties - But I'm pretty positive I have everything correct because I was able to login to my SQL web host account with another computer at work. But can there be something easy I'm overlooking?

I have looked on the Microsoft site and found the following: http://support.microsoft.com/support/ServiceWare/SQL/SQL70/EAFGBOS8E.ASP http://support.microsoft.com/support/kb/articles/q229/6/08.asp http://support.microsoft.com/support/kb/articles/Q267/5/50.ASP

I have tried to do what they say, but have had no luck. I have TCP/IP set in the "client network utility", and "Client for Microsoft Networks" selected as my primary login in my control panel (even tried it without it being my primary login). Can I be missing an essential setup/config here? (FYI: I do have a network card for my cable modem installed)

I am using an Intel machine with the first edition of windows 98.

I have tried the two different install types, "STANDARD" and "DESKTOP" (not exactly sure what the difference is, but I haven't had the chance to get too deep into it because of this current problem... I'm new to SQL Server/Database)

I was told perhaps my Microsoft Management Console may be corrupt and to either reinstall SQL or download the MMC from Microsoft's Website. I did find a place online with a link to the MMC and I downloaded it, and installed it. It was version 1.2. However I am still having the same problem. "Assertion Failed!" - I also tried to reinstall SQL but the error continues.

When I UNINSTALL and try again, I want to make sure I get it all out of there, in the registry I have removed or looked to remove all of the below: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server 7.0 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSSQLServer HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SQLServerAgent

Can there be something somewhere else I am missing that may not have been deleted by needs to that may affect a reinstall? I even tried to update SQL 7 with the service pack 2 file, csb70full.exe and still get the same problem.

Any help is appreciated! George gplemos@email.com

-- Anonymous, September 07, 2000



I could not find any other useful advice. Most of what I found was a restatement of the advice from the third knowledge base article which states: "To resolve this problem, install the Client for Microsoft Networks as one of the networking components on the computer. The Client for Microsoft Networks does not have to be the Primary Network Logon." But you already know this.

I advise you to call Microsoft Product Support Services for assistance. They will charge $249 for the service, but refund it if you can make the case that this problem is due to a Microsoft bug. (In fact, the third knowledge base article calls it a bug! So it should not be difficult to make the case.)

Hang in there. I have run SQL 7.0 and SQL 2000/7.5 Beta 1 on my Windows 98 home machine with cable modem. So I have reason to believe it is possible.

Good Luck,


-- Anonymous, September 08, 2000

Moderation questions? read the FAQ