Cannot start the program : LUSENET : Roland MC-202 Hack : One Thread

1st of all Im a programmer, so I should have figured this out, but I didn't :).

I've installed the Java SDK v1.0.2 on Win97, the path & classlib variables, I go to the classes folder where Hack202.class is, I type java Hack202.class and it says "Can't find class Hack202".

BTW, since the folder name contains spaces, I had to put it under "" in SET CLASSLIB, but, when I renamed it to hack202 and put that in CLASSLIB, it didn't work again.

Any ideas ?

greetings, Nikola

ps congrats for the reverse engeneering :).

-- Nikola Cosic (, June 26, 2000


Re: Cannot start the program


Sorry you're having trouble - you're not the first person to have reported this kind of behavior. I still haven't figured it out, as sometimes people can get it fixed but other times they can't. Something to try is to move all the classes into the Java executable directory, and try invoking Hack202 there (use the command line: java Hack202.. If that still doesn't work, then I give up! I think it has something to do with the crappy Java 1.02 implementation (this program was written several years ago, at the beginning days of Java). In fact, you might try installing a more recent Java runtime environment, that might help too.

The other solution that I have offered people, and many have opted for this solution, is that I have compiled the Java objects into a native Windows application - an .exe and two .dll's. This version has worked flawlessly for everyone that has tried it. The only difference is that this version is pre-pay only (still the same price, US $10).

Let me know if you are interested, and again, sorry for the trouble with the Java version.


-- Dan Nigrin (, June 26, 2000.

Moderation questions? read the FAQ