EZCD 4.02 causes page fault when writing VCD.

greenspun.com : LUSENET : Video CD : One Thread

Help! I'm using Adaptec EZCD creator 4.02 to make VCD's. I load the mpeg file to burn into the video cd creator program which verifies that it is white book VCD compliant. I go on and set up the VCD and set it to burn or create disc image, but either way what happens is that the program will go ahead and begin to create the Video CD data needed to burn or write the disc image with. Everything goes fine until the very very end when it is finished decoding, instead of the next screen coming up asking me if I want to go ahead and burn, the program crashes. The error that comes up is VCDCR32 caused an invalid page fault in KERNEL32.dll. I've tried uninstalling other software such as xing, reinstalling EZCD creator with and without the upgrade to 4.02, defragmenting my drive, deleting my swap file, etc. Nothing works. I'm running WIN98 on a pentium III machine with 448MB of RAM. I previously had NERO installed but I removed it and went through my registry deleting all of its references but to no avail. Anyone who can help me would be greatly appreciated. Thanks in advance.


-- tcanuck (canuck@subdimension.com), March 25, 2000



Send a copy of your win.ini and system.ini file to me for check. I probably can help if you are really desperate..

-- Daniel Lee (siangneng@hotmail.com), March 25, 2000.

yes that is exactly how i fixed my adaptec/xing problem. Canuck in those files even though youdeleted everything, it still will leave it so that the xing is still your default mpeg player and such, this is what is causing your problem. if you are not sure on how to fix this post it here, or send the stuff to Dan who posted above me.

-- Doug (mazinz@aol.com), March 25, 2000.

ez likes to have activemovie as the default player for playback purposes. This is the caused of your vcdcr32 and kennel32.dll bomb. edit your win.ini and system.ini to point to mciqtz.drv. look in your win.ini to see what mpg is pointing to as the association file extension and compare that to system.ini. That same file extension association should be pointing to mciqtz.drv.

-- lnguyen (wingstarzz@hotmail.com), March 25, 2000.

or when you go in these files and you see ANYTHING with xing ( i had 2 lines in each file)still in the name put this directly in front of it(no spacing between the symbol i just typed on the right and the line of code) ; by doing this it ignores that line of code and returns active movie as your default player, so your adaptec will work fine

-- Doug (mazinz@aol.com), March 25, 2000.

Canuck's problem is quite peculiar. His win.ini and system.ini files look ok to me, especially the mci section. Can it be due to Cyberlink's PowerPlayer? Anyone has experience in that?

-- Daniel Lee (siangneng@hotmail.com), March 26, 2000.

I have been having the same problem with EZCD 4 crashing everytime I loaded an MPEG movie... everything checks out okay, but fails to go any further. I would hit ignore, but it wouldn't preview the MPEG, and when I tried to go ahead and burn, it only burnt the VCD/CDI directories.

What I did as a make shift because I was anxious, and to me works SO much better, was using Nero to burn VCDs. I was very pleased with the ease of use, and within 5 mins I was burning away... 20 mins later I dropped it in my Pioneer DV525, and I was watching SWE1! I was so excited that I probably won't deal with EZCD anymore.


-- Scaryguy (scaryguy22@mediaone.net), March 26, 2000.

There are three lines inside win.ini and one line in system.ini which EZ is looking for.

win.ini under [MCI Extension] mpg=MPEGVideo mpv=MPEGVideo mpeg=MPEGVideo

system.ini under [MCI] MPEGVideo=mciqtz.drv

Now if there are other mpeg players or codecs around that associate themselves with MPEGVideo, do remark it out by attaching a semi-colon in front of the line. Otherwise window will get confuse as to what to use for default codecs. Once this is done then EZ CD will be more then happy to check and write the VCD for you. Also you must have activemovie and directX install in your system for all of these to work (just a reminder).

-- lnguyen (wingstarzz@hotmail.com), March 26, 2000.

Greatly appreciate all the suggestions offered. However haven't had any success. Already made sure any references to Xing were gone from my system.ini after removing it from my computer. I'm trying to follow up on Daniel Lee's suggestion of following up on the PowerVCD. Had this program installed earlier and have now removed it from my system. I checked the installation file for this program to see what it installed and found a file called "setupapi.inc". Although this file is not on my system "setupapi.dll" is. It's loaded up under the 32-bit modules and described as a "Win NT setup api file". Do not know if this is a normal file to find on a WIN98 system. Does anyone have any ideas about this?

Also to clarify the problem, the program crashes not when I initially load the mpg into EZCD but at the very end of the VCD mastering/preparing process. In other words after it has crashed I can go into my windows temp directory and find a temp file created by EZCD that is probably the complete or almost completely done VCD file ready to be burned or created as an image file.

Again thanks for the help, and if I can't figure this one out I guess I'll just try Nero next.


-- tcanuck (canuck@subdimension.com), March 26, 2000.

ahhh...Nero & EZ....i.c. goes to ahead and download the bootable menu for Nero and EZ CD to exist together in your system. I have Nero, EZ CD, and Cequadrant softwares on my system. If i want to use either one, all i have to do is reboot my system and press f8 before window loads up to choose which software i want to use for my burner, and all is well. Sound like you still have a remnant of Nero around somewhere.

-- lnguyen (wingstarzz@hotmail.com), March 27, 2000.

Moderation questions? read the FAQ