Tracking problem : LUSENET : S-Mart Shopping Cart : One Thread

I get this message when executing by telnet.

Undefined subroutine &main::GetCookies called at ./smartrack.cgi line 72

Can someone please help?

-- Jeff W. (, February 01, 2000


Hmmm. I don't use smartrack, however, you sould check and see that cookies are turned off (0) in smart.cfg. That feature does not work in S-Mart.


-- Stephen Warriner (, February 01, 2000.

I do have cookies turned off.

-- Jeff W. (, February 01, 2000.

Two ways: Have a look at smartrack.cgi, right below the copyright info you have the following lines:

# Measure CPU time usage; $start = (times)[0];

require 'smart.cfg'; require 'cookie.lib';

there4s the problem !!!! Either remove require 'cookie.lib' or copy a cookie.lib into your dir !

-- Daniel Mikhail (, February 02, 2000.

I tried both of those suggestions it still has the same error.

-- Jeff W. (, February 02, 2000.

In addition to the above this might help. My smartrack.cgi runs but doesn't work, I don't know why. I gave up on it. But go to line 72 or find:

elsif (&GetCookies('smart')) {
	$trackid = $Cookies{'smart'};

and remove those lines. Not sure if that helps you, but my script runs but not properly.

-- Ekin (, February 06, 2000.

Moderation questions? read the FAQ