1st item of any group isn't added on clicking "Add", PART 2

greenspun.com : LUSENET : S-Mart Shopping Cart : One Thread

[Continuance of first thread-- for some reason, the button to add a reply doesn't work...]

Stephen (stephen1114) suggested the existence of unmatched td/tr/table entries which I believe I have squashed. Thanks!

The problem still exists, where clicking "add" for the first item of any group listing results in a redraw of the header/footer and only the field header line-- no data. Clicking "add" on other entries momentarily displays the record is added and redraws the screen with the items as it is supposed to.

Any other ideas? I'm tinkering for awhile, as we're submerged in ice right now in Moore County, NC...

-- John White (jwhite@mindspring.com), January 30, 2000


Its a misconfiguration in the generated tables, check this one more time. Becose when I corrected this it worked for me. Shoose border="1", and you will se the error.

-- Kevin F (nubben17@hotmail.com), February 09, 2000.

Many thanks for the info! After Stephen informed me of the closing tag problems, and my first attempt didn't work, I chose to set it down for a couple days-- came back two days later and reading the code I found a tr that was missing-- low and behold that did the trick! Taking an extended break from something can do wonders!!! ;>)

Consider this thread SOLVED!

For those interested, my smart page is at http://www.fdcusa.com/cgi-bin/S-Mart/S-Mart.cgi. Still have some ideas to work out-- one is addition of a Last-Update field for since (n) days quiry, which I will open a new thread for.



-- John White (jwhite@mindspring.com), February 11, 2000.

Moderation questions? read the FAQ