Tempest 512k, anyone get it to play back?

greenspun.com : LUSENET : MAME Action Replay : One Thread

Obviously it can't be verified with xmame 36b4 as stated in the description because it's not out yet :) But i've tried dos mame 36b2 + 36b4 and get the same ruptured score 245k.

-- Chad (churritz@cts.com), September 13, 1999


An unofficial patch was released for 36b4.

-- Dave Kaupp (info@kaupp.cx), September 14, 1999.

I played it back with defaults and then setting it to hard. Same results as above.

I think I've had problems playing back my inp's when I had .cfg or .hi files laying around on win32.

-- Dave Kaupp (info@kaupp.cx), September 14, 1999.

I think i'll try inserting a header, since macmame doesn't record haeders. i'll bet one frame from the missing header could through it off ONLY if there was a close call where the play needed to move away at exactally one frame, which might not happen for a while. IF that is the cause i'll see if i can create an exe to autocheck/set headers by version number before playback. Anyone know the first mame version mame started to record headers with the game name in?

-- Chad (churritz@cts.com), September 14, 1999.

That's odd. I replayed it under the following versions: MacMAME 36b4 running under MacOS 8.6 on an 8500 w/ G3 and a 3400c. xmame 36b3 under FreeBSD. I had to specify the ROM. DOS MAME 36b4, under Windows 98 (full screen). I also had to specify the ROM.

My FreeBSD and Windows 98 machine is an AMD K6-2-based PC (dual boot).

MacMAME ignores the configuration and high scores when it plays INPs. And I haven't had specific problems under DOS or xmame, either.


-- Ken Lui (tempest@ecst.csuchico.edu), September 14, 1999.

Ok, even with the forced header record "tempest\0\0\0\0..." i couldn't get the dos playback passed 245k, but with xmame36b3 i was able to play it back to the 516k with the extra header AND with out (and specifying tempest on command line.) Dang those invisible levels must be fun :) If anyone was able to get it to playback with a dos email me with the opts / mame.cfg you used.

-- Chad (churritz@cts.com), September 15, 1999.

Well, I checked my original INP file and sure enough it doesn't play after 245K under DOS MAME. It plays fine under MacMAME 36b4 and xmame 36b2/36b3, though. I guess it's not enough if the INP plays fine for 10 minutes--I got tired of watching the INP for the fourth time (40 minutes duration) and assumed it worked under DOS, too.

Sorry for the confusion. I've updated the entry to reflect that it doesn't playback under DOS.

-- Ken Lui (tempest@ecst.csuchico.edu), September 15, 1999.

Yes, I tried the same thing Chad. I padded the beginning of the tempest.inp file with "tempest" then 25 NULL characters after it.

I got the same thing, no way would it playback beyond 245K under DOS. What a shame, I really wanted to watch it all the way through.

I'm pretty sure mame 36 betas use a 32 byte header, but I'm not 100% positive.

I'm glad to hear you got it to work with xmame 36 beta 3. I guess this one is a special case. No go at all on Ken's Missile Command 300K with only 6 cities. Can anyone verify this one?

-- Mark Longridge (cubeman@iname.com), September 15, 1999.


I didn't post Missile Command here because I only could get it to replay under MacMAME, and neither DOS MAME (test mode) nor xmame (X/Y axis screwed up). Your site mentioned having a better facility to cater to MacMAME-created INPs but I guess the problem comes from OS versions? I will have to check out what happens when using OS 8.5.1.


-- Ken Lui (tempest@ecst.csuchico.edu), September 15, 1999.


-- sikorski zbyszek (zoolook1@poczta.onet.pl), January 02, 2001.

Moderation questions? read the FAQ