Smartadmin - Glitch when editing items : LUSENET : S-Mart Shopping Cart : One Thread

Greetings! In my implementation of the catalog, I have rather lengthy item descriptions, along with links to articles. I have noticed, when I attempt to use the Admin script to Edit an Item, it only retrieves some of the text from the "descrip" field in the database.

Has anyone else encountered this particular problem? If so, are you aware of a remedy to the problem? Your input is greatly appreciated!


Pat Dupuis

-- Patrick Dupuis (, May 12, 1999


Edit the smartadmin.cgi file and find where the form is printed. You are looking for a line like this: Item Description:\n

Just change size=60 to size=whatever, or just remove the size= tag entirely. You might also want find where the items are edited ( print "Description:\n"; ) and change that also.

-- Russell Flowers (, May 15, 1999.

Thanks for the info Russell. I tried your recommendation, and it did not change anything. My "description"s have numerous hyperlinks included with them as well -- I'm wondering if they somehow interfere with the functionality of the smartadmin script when retrieving the info from the demo.db file. Since my descrips were so lengthy, I changed the description input field to a textarea. Originally, when trying to edit an item with the description input field as a simple text box, the contents would jump out of the text box and mess up the record when I tried to edit. The textarea has taken care of that problem. Do you suppose that there may a problem retrieving a record from the demo.db file if the line wraps for a particular record?

BTW - thanks for the insight.


Pat Dupuis

-- Patrick Dupuis (, May 15, 1999.


The item name is able to have a hyperlink set to it. If you place a short decription and say "For more information click on item name" Then create your own web page with all the information and links you need. Trying to edit the script to work might be the long way around when you can have all the information you need on its own page.


-- James L. Farmer (, June 07, 1999.

I discovered that using " in the description makes it imposable to edit. It also causes the image box to disappear. I replaced all my " with ' and it worked fine.

-- Eddie Deboard (, October 30, 1999.

Moderation questions? read the FAQ