Register a server : LUSENET : SQL Server Database Administration : One Thread

My computer is running WinNT 4 Workstation. I have not specified a Domain but a Workgroup. I created an sql server service account and installed sql server 6.5 developer's edition on the same machine. I can not register a server from Enterprise Manager Register Server window. I get the following msg:

"Unable to connect to server (reason:[DB-Library] Unable to connect. SQL server is unavailable or does not exist. Specified SQL server not found) Register anyway?"


What's the matter?? Please help. Thanks, John

-- Anonymous, September 14, 1998


Re: Register a server


Here are a couple things to check:

Check the services on the machine. It almost sounds like the server isn't running. There should be two services. One should be for the SQL Executive and the other should be the MS SQL Server. They should be started.

As for logging in, if you are using Standard security use the username sa without a password (that is the default when SQL Server is installed).

If you are using Trusted security, since you don't have a Domain and trust relationships setup, log on to the machine running the Server as a user that is in the Admin group of that machine. By default, anybody who is an admin on the machine will be automatically mapped to sa.

Hope this helps,


-- Anonymous, September 15, 1998

Register a server?

Eric: Thanks for your reply.

I have gotten a little further on the thing. If I name the server "(local)" and use "sa" as the login name, it will register the server "[LOCAL]". However, when I try to start the server, I get "error 1722 - [the RPC server is unavailable] occurred while performing this service operation on the MSSQLServer service." Both MSSQLServer and SQLExecutive are running. In the SQL Server manager window it shows the server state "indeterminate".

I'm determined to learn this stuff... with some help from you.

Thanks, jw

-- Anonymous, September 16, 1998

Re: Register a server? [error 1722]


The following excerpt from a Knowledge Base article might help.


------------------ PSS ID Number: Q155283 Article last modified on 09-10-1996 PSS database name: SQLSERVER 6.00 6.50 WINDOWS

------------------------------------------------------------------------- The information in this article applies to: - Microsoft SQL Server, versions 6.0 and 6.5 ------------------------------------------------------------------------- SUMMARY ======= The SQL Executive component of SQL Server is responsible for running various aspects of server operations such as replication and task scheduling. This article is to help troubleshoot why SQL Executive might stop running or executing tasks. MORE INFORMATION ================ SQL-DMO ERROR MESSAGE - 1722 If, at any time, you have changed the NT computer name, but not the SQL Server server name, and the @@SERVERNAME variable is not NULL and does not match the Windows NT computer name, you must execute the sp_drop server and sp_addserver ,LOCAL commands to alter the SQL Server name. For additional information, please see the following article in the Microsoft Knowledge Base: ARTICLE-ID: Q140683 TITLE : INF: Run Task May Cause 1722 Error To find out what SQL Server thinks the server name is, execute the following command: SELECT @@SERVERNAME or view the server name in the SQL Server error log located in the Sql\Log directory. The SQL Server server name must also conform to the rules for identifiers. Stop and restart the MSSQLSERVER service for the LOCAL parameter to take affect. LOGON ACCOUNT SQL Executive has two ways to log on, either as the System Account or This Account. The general recommendation is to create a user account in the domain\administrators group with the following attributes: Account Information User Name : SQLServer Full Name : SQL Server admin account Description : SQL Server administration account Password : Confirm Pass : Account Attributes x User cannot change password x Password never expires Member of Domain Administrators A frequent cause of failure in this situation is that the account that SQL Executive is using has a password that has expired or changed. If this is the case, enter the correct password information for SQL Executive in the Control Panel Services applet and then stop and re-start the SQL Executive service. LOCAL GROUP MEMBERSHIP If SQL Executive is logging on as This Account, you should verify that the account is a member of the local computer's Administrator group. If the account you are using is not a member of the local administrators group, add it. This is important and if not done, will prevent SQL Executive from being able to log on properly. If you are still having problems getting SQL Executive to log on properly, there is probably a permissions restriction in the registry. Check to see that the administrators group and local system account have full control on the SQL Executive folders in the following locations: HKEY_LOCAL_MACHINE on Local Machine \SOFTWARE \MICROSOFT \MSSQLServer \SQLExecutive and HKEY_LOCAL_MACHINE on Local Machine \SYSTEM \CurrentControlSet \Services \SQLExecutive If you are still seeing errors like 109 or 1069 when you try to start SQL Executive, you can try rebuilding the registry for SQL server. Make sure that you are logged on to Windows NT as the local administrator, or someone with local administrative privileges, and follow the steps listed in the following Microsoft Knowledge Base article: ARTICLE-ID: Q119401 TITLE : INF: Rebuilding SQL Server Entries After Reinstalling Win NT NETWORK PROTOCOL ISSUES SQL Executive requires a Net-Library that allows a trusted connection. The only Net-Libraries that support a trusted connection are named pipes and multi-protocol.

-- Anonymous, September 17, 1998

I had the same error. I solved it by going into ODBC via the control panel. Here I found one DNS set to LOCALSERVER. I set up a second DNS using the name of my local machine (whatever you called your NT box when installing SQL). I used the sa username and left the password field blank. I then went back to Enterprise Manager and re-registered the server. This sorted the problem.

Another thing to check is that the server is actually started - right click on the server and choose start. I hope this helps.


-- Anonymous, August 13, 1999

Moderation questions? read the FAQ