Script will not retrieve products from .db file? : LUSENET : S-Mart Shopping Cart : One Thread

When I run the script, the front page comes up. However when I try to "search", "list all products" or "select category" the next page is just the products.

When I run the script from telnet (hoping to find the bug), it executes just fine. What am I doing wrong?

-- Jonathan Griffin (, January 06, 1998


You must ave set the "chmod" to 777 on all your database files. If using WSFTP to transfer files to your web on the top "remote host" field, choose "site" and type "chmod 777 xxxx.db". xxx is whatever the name of your database file is. I had the same problem. I had overlooked this step in the readme file.

-- Toby Seavey (, January 06, 1998.

I have the same problem but the permissions are corrects. Please can you tell me where the demo.db is supposed to be place exactly? idem for the tmp file. Thanks

-- Sibastien (, June 04, 1999.

Try to set $useadmin = 1 in smart.cfg file

-- FRank (, November 15, 1999.

Moderation questions? read the FAQ