greenspun.com : LUSENET : Roland MC-202 Hack : One Thread


-- RICHARD HOWARD (106564.610@compuserve.com), October 25, 1997


Re: ColorpickerLib

Richard: That's a new one, never heard that bug before. First off, I need some more details, re: where you got the software, and what your Java and system environment is like:

1- Did you get the software off the 202 Hack web site, or did you get it off the Future Music CD? If it's the latter, I can't vouch for it, as they distributed the code without my permission, and I know for a fact already that the PC code is corrupted on the CD - perhaps the Mac code too.

2- I need to know which version of Java you have running (MRJ 1.02 or 1.5 or what), your OS version, etc...The more details the better.

-- Dan Nigrin (dnigrin@welchlink.welch.jhu.edu), October 25, 1997.

202 Hack & 'ColorPickerLib'

Dan :

Thanks for the reply.

1) Yes it came off the Future Music CD

2) Power PC 8100/80 System 7.5.5. MRJ 1.02. CFM-68K 4.0.(I don't know if I need this on a PPC Machine I've tried it with and without it made no difference. )

I also did a search for the File 'ColorPickerLib' at Apple and Yahoo The Apple search came up with nothing. Yahoo found a couple of messages, about someone getting the same Alert I did, when they tried to launch another Application. The reply to the message stated, something along the lines of.. being able to tell the Code Fragment Manager not to be too fussy and let an application launch even if it can't find a library, and that certain versions of CFM are unstable. I think you would understand all of this better than me.

I'll try downloading from the 202 Hack web site and let you know how I get on.

-- RICHARD HOWARD (106564.610@COMPUSERVE.COM), October 26, 1997.

Re: ColorPickerLib


1) Yeah, I would definitely get the software off the web site first. If that doesn't work...

2) Are you sure that Java is operational on your machine? When you download the Java environment (if I remember right), it includes some sample applets that you can run. Knowing if those work or not on your machine will help me out.

In general though, there's absolutely know reason why 202 Hack shouldn't work on your machine - it's almost identical to the machine that I developed the program on...

Oh, last thing, I just wanted to make sure that you rebooted after removing CFM-68k, right?

Keep me posted, we'll figure it out!


-- Dan Nigrin (dnigrin@welchlink.welch.jhu.edu), October 27, 1997.

re: 202 Hack ColorPickerLib

Dan: I Downloaded via Web Site.... No Luck. I get the same 'can't find'.. etc

The Apple Applet Runner runs on this machine. And yes I did Re-boot after removing CFM 68K.

I'll soon be installing System 8 Maybe this will solve the problem.

Thanks, Richard.

-- Richard Howard (106564.610@compuserve.com), October 30, 1997.

ColorPickerLib Mac

Richard: Yeah, loading up OS 8 might help, as I have a feeling there's something funny about the current Java installation on your machine (it *can* be flaky, especially on the Mac).

One last question though - can you just double click on JRunner, with no error messages? (that is, rather than dragging the class file onto it). If you still get the same error message, then I'm sure there's something wrong/weird with the current Java environment....

I've also searched a bit on the web for bugs relating to Colorpickerlib and Mac Java, but didn't find anything....

FWIW, I'll soon be releasing standalone executable applications of 202 Hack, definitely for Mac, and probably for PC, within the next couple weeks/months (as soon as I get some time). This will hopefully solve the problem, if nothing else does.

Keep me posted about any progress you make, and I'll keep thinking / looking for the answer as well. Thanks for your persistance with this one!


-- Dan Nigrin (dnigrin@welchlink.welch.jhu.edu), October 30, 1997.

Got it!

Richard: OK, found the problem!

I searched my Mac for anything that had the word "color" in it (rather than searching for "colorpicker" or "colorpickerlib". Sure enough, there's an extension that's called "Color Picker". I tried removing that from the extensions folder, rebooting, and then sure enough, I got the exact same error message you get when I tried to drop "Hack202.class" onto the JRunner icon....

If you can't find that extension on your machine, I'd be happy to e-mail it to you, or perhaps you can find it on the apple site.

Let me know,


-- Dan Nigrin (dnigrin@welchlink.welch.jhu.edu), October 30, 1997.

Moderation questions? read the FAQ